Accidentally Uninstalled Graphics Card?

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Accidentally Uninstalled Graphics Card?

This question is not answered

alright so i think i accidently unistalled my graphics card or something.. So i went to Start > Computer right click > Properties > Device Manager > Display Adapter and went over my Raedon 7970 and accidently clicked uninstall.. Now my computer only runs the intel 4000 graphics card.

How do i get my raedon 7970 back?

Btw im on Alienwre m17xR4 with AMD 7970

it didnt come with a cd from graphhics card..

Thanks.

what ive tried so far..

i went and downloaded the drivers and installed them and that didn't work. i can still only select the intel graphics 4000

All Replies
  • Anyone please

  • bump

  • Hi MustafaHadaKing,

    I would advise you to uninstall the ‘catalyst control center’ & ‘Intel HD graphic drivers’ from ‘Programs and Features’ under the control panel and reinstall it in a sequence given below to get back the integrated and discrete video cards on the system.

    Please follow the link below. When the page comes up please put in the service tag of your computer. Then go ahead and download the ‘Intel Graphics Driver’ first and then ‘AMD HD7970M 8.973 Win 7 64 Driver’ from Video section and install it in sequence , after selecting the operating system installed on your computer, from the link below.

    http://dell.to/ZaQuel

    Please let me know if this helps.

    Thanks and Regards,
    Ravi Chandra BC
    Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • thanks for the reply, but that did not work.

  • I just accidentally did this and it turned into a bit of a mess. I uninstalled them, and then tried to install the new beta drivers but the driver installer wouldn't recognize my 7970m. So i went on to dells driver page and downloaded the original driver, and while it worked, it wasn't working exactly right and I had half the normal performance I used to have even after trying to install newer drivers than the ones from dell. I ended up doing a factory restore because my backup USB drive somehow got corrupted. After re installing everything the way I wanted it and updating to the newest drivers it works fine now. I would try just installing from dells page, but if that ends up not working doing a factory restore.

  • Hi MustafaHadaKing,

    If re installing the driver didn't work, you can always restore the system back to a date when it was working fine:

    How to run Windows® 7 System Restore in your Alienware™ computer 

    Natalia J
    Dell | Alienware Technical Support Alienware Arena
    Opening your case and/or replacing parts yourself does not void your warranty!
    YouTube Logo Check out our disassemble videos on YouTube
    If you need extra assistance please use Facebook Logo Twitter Logo, I can't always reply to PM's

  • Hi MustafaHadaKing,

    I would like to know the exact error message you are receiving when you try to install the AMD graphics driver.

    Thanks and Regards,
    Ravi Chandra BC
    Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • it installed fine but when i clicked catalyst control it wouldnt let me open it and said there's an error with the catalyst control. i dont remember the exact message but i guess ill have to try same process again and see what it is.

  • Hi MustafaHadaKing,

    I would advise you to Re-flash the latest BIOS and then install the video drivers for your system.

    Please follow the link below. When the page comes up please put in the service tag of your computer. Then go ahead and download the BIOS and ‘Intel Graphics Driver’ first and then ‘AMD HD7970M 8.973 Win 7 64 Driver’ from Video section and install it in sequence , after selecting the operating system installed on your computer, from the link below.

    http://dell.to/ZaQuel

    If the above step does not resolve the issue then I’d suggest that you run the diagnostics on the computer by following the steps mentioned below and check if there is any issue with the hardware on your system.

    1. Turn on or restart the computer.
    2. Immediately at the Dell logo screen, starting tapping the <F12> key once a second until the One Time Boot menu appears (if the computer boots to Windows turn the computer off and try again).
    3. At the One Time Boot menu, press the <Down> arrow key to highlight Diagnostics, PSA+ or Enter ePSA, then press <Enter> to begin the hardware Diagnostics.
    4. Write down any error codes listed. Reply to us with the error codes.

    Please let me know if this helps.

    Thanks and Regards,
    Ravi Chandra BC
    Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • hi, sorry for the late response but i tried what you said and it did not work. Also when i did the diagnostics it did not come with any errors.

  • Hi Mustafahadaking,

    If you go to the device manager, do you see a standard VGA adapter? Do you see something else listed under other tab?

    Alexander J
    Dell | Alienware Technical Support Alienware Arena
    Opening your case and/or replacing parts yourself does not void your warranty!
    YouTube Logo Check out our disassemble videos on YouTube
    If you need extra assistance please use Facebook Logo Twitter Logo, I can't always reply to PM's

  • nope i don't see that. I see AMD Radeon HD 7970M & Intel(R) HD Graphics 4000

  • That means the AMD driver was installed by windows. I would recommend you to uninstall the Catalyst Control Center from Programs and Features and install the latest driver from the manufacturer's website.

    Alexander J
    Dell | Alienware Technical Support Alienware Arena
    Opening your case and/or replacing parts yourself does not void your warranty!
    YouTube Logo Check out our disassemble videos on YouTube
    If you need extra assistance please use Facebook Logo Twitter Logo, I can't always reply to PM's

  • ive tried that and that didnt work