Alienware m17x 1103 wireless connnectivity problem

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Alienware m17x 1103 wireless connnectivity problem

This question is not answered

Hello,

I have an Alienware m17x R3 running Windows 7 Pro with the Killer Wireless-N (1103) option.  I can connect via the ethernet connection though I am unable to detect any wireless networks when I enable the wireless adapter.

Adapter driver information: v 9.2.0.209

Bigfoot Killer Network Manager: v 6.1.0.140

I should note that the Network Manager does not see the wireless adapter and checking the adapter status in the device manager does not show any problems.

Could the antenna be disconnected?

What other software components are needed for the wireless adapter?

I have searched through a variety of threads on solutions, though I wanted to diagnose the card/driver more before I mangled the system with a bad update.

All Replies
  • Hi Derek1791,

    Request you to uninstall/Reinstall Killer Wireless-N (1103) once by following the below steps:

    (1) Go to start.

    (2) Click on Programs and Feature in search box.

    (3) Programs and features dialog box appears, now click on wireless

    (4) Detect Wireless 1103 driver, right click and click uninstall.

    Then Use the below link and download Killer driver:

    http://dell.to/UD3Ucc  

    Thanks and Regards,
    Kiran Kumar
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • Do I uninstall the driver separately or just the Killer application itself?

  • When you uninstall the driver, that should uninstall the killer application as well. If not, go ahead and uninstall it. Also, use the driver cleaner in this article to get rid of the driver completely:

    Click here.

    And just like the article states, update the .NETframework.

    Let us know how it goes.

    Alienware-Natalia
    Dell | Alienware Technical Support Alienware Arena
    #iwork4Dell
    Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
    I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

  • Hi Derek1791,

    That’s right if the driver is uninstalled even the application should get uninstalled, if this doesn’t happen please uninstall it manually and follow the steps given by me in the above post.

    If this doesn’t fix the issue then you may use the link below and download drivers:

    http://bit.ly/P6f2AY

    Select product category as wireless, product model as killer Wireless-N1103, Download type as driver and then the Operating system.

    If you have any further questions please reply to the same post.

    Thanks and Regards,
    Kiran Kumar
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98

  • I did the followinimg:

    Confirmed that the net framework was up to date.

    Uninstalled the bigfoot network app.

    Rebooted and ran the bigfoot cleaner.

    Rebooted and installed the bigfoot app from the link you provided.

    I enabled the wireless connection and still could not detect any nearby networks.

    Also, the killer application crashes immediately upon starting it.

  • It looks like my AV software may not have been disabled.  I will try again tonight.

  • Hi, download and install the driver Version 6.1.0.298 from Bigfoot Networks, perhaps that could help. If you get signal bars at all, the antenna should be ok. The only components needed are the motherboard socket and the wireless card + antenna

    Alienware Lizano
    Dell | Alienware Technical Support Alienware Arena
    Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
    I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo

  • I repeated my steps with zonealarm disabled during reinstall and saw the same results.

    Next, I uninstalled the wireless driver from the hardware control panel.

    When I attempted to install the latest killer drivers I received an error message indicating the current killer networkmanager must be uninstalled.

    I followed the same steps as before, except with zonealarm off during reinstall and using the latest killer manager/driver.

    Now the network manager runs without crashing though the wireless still does not detect any other networks.

    Also, after rebooting from uninstalling the wireless above I have lost ethernet connection as well!

  • I forgot to add that I created a restore point before I started updating the network drivers.

  • Any suggestions on the next step to try?

  • Hi Derek1791,

    The first step is to try installing the killer wireless from the support site as I mentioned and then from the killer website. If you have tried both and nothing worked then I suggest you to send an email to AWCC-Resolution_Experts@Dell.com (for US and Canada customers) with the system service tag, phone number and proper time to reach him and someone from Dell (Alienware Support) will contact you.

    Thanks and Regards,
    Kiran Kumar
    Dell Social Media and Community Professional
    Order Status : http://dell.to/1fgKSTr
    Download Drivers : http://dell.to/1hcxG98