x51 HDD not upgradeable?

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

x51 HDD not upgradeable?

  • I just purchased the X51 and wanted to put a bigger HDD in it ... so i purchased a 3TB drive and put it in.

    Upon rebooting I get a message  saying that there is no HDD in the machine, even though it lists it in the bios, and in the alienware test thing it says it's all good.

    Since this failed I also tried with a 2TB drive and 750GB drive with the same outcome.

    Any suggestions on how to fix this would be appreciated.

    Thanks
    |Kris 

  • Having the same problem.I bought a Kingston ssd from Dell to install in mine.I plugged it right in but I get the same error you get no HDD detected.Never seen anything like this before.

  • Are you in legacy mode or UEFI mode in BIOS?

  • I thought it may be something to do with that...  

    But it is grayed out and won't let me change it.

    I also got it working with the new HDD though..

    But now have another problem...

    basically booted it with the cd that came with it and it put windows on my HDD and started working... But it doesn't seem to let me.boot off any other disk?? .. which is why I thought it was stuffed....

    I do not want home premium on it.. how can I boot off another disk ?

    Thanks

    Kris

  • <quote>I thought it may be something to do with that...  

    But it is grayed out and won't let me change it.

    I also got it working with the new HDD though..

    But now have another problem...

    basically booted it with the cd that came with it and it put windows on my HDD and started working... But it doesn't seem to let me.boot off any other disk?? .. which is why I thought it was stuffed....

    I do not want home premium on it.. how can I boot off another disk ?

    Thanks

    Kris </quote>

    How did you format your HDD?  Did you use NTFS?  What Allocation unit size?  It should allow you to boot from other OS discs.

  • update to BIOS A02 and the option will be available to change to legacy.  If you plan to stay with UEFI don't switch to Legacy mode...

    UEFI is a new way of addressing disks with a single volume over 2TB.   But with legacy and volumes at or below 2TB you can use legacy mode.  

    The windows CD that came with the system is designed to work with UEFI and by the way Windows 8 when it releases later this year will be UEFI enabled as well.  It's the future....

    Did some digging on google to find all this stuff on how UEFI works.  It's definitely not BIOS anymore.

    here's some microsoft info on it.

    technet.microsoft.com/.../cc749064(v=ws.10).aspx

    Also here's an explanation of why you need to use UEFI with 3TB drives especially if you want to BOOT from them:

    www.pcworld.com/.../everything_you_need_to_know_about_3tb_hard_drives.html      

  • Thanks have upgraded the BIOS now ... but that still wouldn't explain why i cannot boot off a windows server 2008 R2 CD .... would it?

    Kris

  • That's because windows server 2008 R2 seems to have an issues with UEFI and apparently a hotfix.

    support.microsoft.com/.../975535

    So I think either that fix will help ... or you would need to switch to "Legacy" and make sure no partition exceeds 2TB.

  • I was planning on cloning the HDD that comes with the x51 (minus the restore partition) using Norton Ghost 15.  I have formatted the 256GB SSD using NTFS.  Anything I should know, or should I be good to go?

  • I was planning on cloning the HDD that comes with the x51 (minus the restore partition) using Norton Ghost 15.  I have formatted the 256GB SSD using NTFS.  Anything I should know, or should I be good to go?  I would rather just keep UEFI, since that is the way things are going.

  • i've heard norton ghost 15 has GPT/UEFI support but haven't tried it.

    I've heard good things about the latest version of Acronis and UEFI/GPT though.  

    Here's an interesting article on how to make USB media bootable in UEFI

    http://forums.bit-tech.net/showthread.php?t=209045

  • But that article makes it appear that it will still boot off the CD... with mine it just looks like a non-bootable cd is inserted

  • i00

    But that article makes it appear that it will still boot off the CD... with mine it just looks like a non-bootable cd is inserted

    It might be related to the optical disk problems everyone else is having (check other x51 threads).

    If so, use a USB DVD-ROM drive ... or just copy it to a flash drive and boot it.


    Alienware Aurora ~ Intel i7-930 ~ 12gb ram ~ AMD HD-5870
    256gb Samsung 830 SSD / 1tb HDD ~ LG Blu-Ray ~ USB 3.0 PCIe
    Dell 24" UltraSharp u2410 LCD ~ Dell 22" LCD

    All my Dell Machines and Specs

    Wiki-like Threads I've written and other Favorites

    Posting Tips:
    - Always provide machine make, model, specs and software versions.
    - Click the button if we answered your question.

    Registered Microsoft Partner
    & Apple Developer:

    Gaming when I'm not programming.

    I answer questions here, but
    I'm not a Dell employee.

  • Got mine working.I used a 2.5 to 3.5 adapter to mount my ssd.I had to snap off the metal stand outs that held the hdd plug to make it fit.The plug is tight against the case so it can't come loose with the drive bay screwed in place.I got the no hdd present error but put the win 7 cd in and it booted and installed off of it with no problems.I ordered my molex y splitter and sata y spliter tonight.All I have left to do is mount the 2.5 laptop drive and make the connections when my cables come.I could probably get by without the 2.5 drive but I just want some on storage to save a few things to.

  • Well i got mine working yesterday morning ... booted off their cd and then installed on the HDD ... still won't boot off anything else (although i have not tried since updating to A2).  Then put server 2008 r2 on it by installing through windows rather than booting off the CD.

    Now have 16GB ram and 3TB HDD in my x51 :) .... using the intel videocard though... i can't believe they shipped this thing with the 550 GTX... 1 min in skyrim and it's overheating and resetting.... I never intended to use this for anything else other than a email / web server though ...

    Kris