Alienware M17X, freezing/crashing/black screen, worst product I have ever owned

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Alienware M17X, freezing/crashing/black screen, worst product I have ever owned

  • I purchased my M17X during the summer of 2009 before my freshman year of college. I wanted a computer that could be a laptop, and play games. When I first got my computer I was so excited to finally have my own personal computer, and it was an Alienware, the brand I wanted since I heard about them. However, the problems starting happening after about a month or two of receiving the computer. They were seemingly small, and were fixed quickly by dell tech support. However, the first major problem occurred within the first few weeks of my first semester at school, the hard drive failed and had to be replaced. I agreed to install the hard drive myself after the technician quickly explained how to do it, and was able to remove the hard drive and install the new one in a matter of minutes. I was surprised however when I saw a Seagate hard drive in my 2500 dollar laptop. Really Alienware, a Seagate?? At least the replacement they sent me was a Western Digital.

    After that problem was fixed, I used the windows 7 install disc I was sent from microsoft for their deal of purchasing a new computer in a given time frame, to install windows 7 on to my computer. I soon became proficient at installing the operating system because I have had to reinstall it about 20 times in the past 2 years because every time I start to have troubles with the computer and call tech support, they always tell me the same thing. Reinstall win 7 and update the drivers. Which it works, for a short period of time, only to begin to fail again.

    One of the times I was reinstalling windows, I flashed the bios as I had always done, and as the tech support technicians did, and the computer froze halfway through the process causing it to be a brick because the ROM was only partially rewritten. Dell told me to send the computer in and they would fix it, which they did. However, upon receiving my computer back it began to have problems with again freezing, being slower than molasses, and wireless not working at all unless the computer was inches from the router. Which they told me to send the computer to their repair again, which I did.

    Now I have the computer, it runs great...When it actually runs. The wireless works, but in the past night have trying to study for finals it has froze multiple times, one night 3 times in three hours. One time the screen went black, and caused me to hard boot the system like I always have to do when it freezes.

    So, in conclusion, I have lost a lot of faith in this company I used to think highly of. I absolutely love my laptop when it works correctly, but that has become so rare I usually don't use it and instead use the gaming rig I built personally. Getting close to the three year mark of owning my laptop, when the warranty runs out, and getting ever so close to graduating college, and commissioning as an officer in the USAF, I am looking to purchase a new laptop. If I can not fix my laptop and end on a high note with Alienware, I will never purchase another one and will instead be buying a Lenovo this summer. I have been very disappointed in this company, and since it is a company I use to like and still do, I hope that the issues I have had with my computer can be resolved which would lead to me being a returning customer of Alienware in the future.

  • Since the Return To Depot repairs did not take, I would ask for a system exchange. Understand, it would be a "like for like" Used System Exchange. Just contact Technical Support and present your case.

    (Liaison for Desktops, Alienware, Monitors)
    Would you like to be a Dell Community Rockstar?

  • I had major freezing issues last year, including the black screen.  I pinned it down to the video card.  NVIDIA's drivers were corrupted to the point that even a fresh install wasn't working.  

    I had to perform a clean install of NVIDIA, using the program DriverCleaner Pro to uninstall any remnants of NVIDIA from my system.  Once that was complete, I re-booted into safe mode.

    ( if you're install package is from Dell )

    Just open and install the Dell version drivers. Reboot into Normal Windows.

    ( if you're using NVIDIA downloaded drivers )

    Open the install package.  Once you get past the user agreement, you'll be presented with a screen that asks for Express or Custom.  Choose Custom.  From there you'll see a screen that has a check box near the bottom.  It says, "Perform a Clean Install". Check that and continue. Reboot the PC back into normal Windows.

    Hopefully, should resolve your problem.