m14x nvidia optimus gt555m problem - Alienware Forum - Alienware Club - Dell Community

m14x nvidia optimus gt555m problem

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

m14x nvidia optimus gt555m problem

  • Hello all.

    Last week i purchased and recieved an AW m14x specs as follows


    Genuine Windows® 7 Home Premium, 64bit, English
    Intel® Core™ i7 2630QM 2.0GHz (2.9GHz w/Turbo Boost, 6MB Cache)
    6GB DDR3 at 1600MHz
    3.0GB DDR3 NVIDIA® GeForce® GT 555M using NVIDIA Optimus™ technology
    500GB 7200RPM SATA 3Gb/s
    14.0" High Def+ (900p/1600x900) with WLED backlight




    (all photos from my iphone, screen captures dont always seem to work)


    after I got it, I installed various games and hoped to see what this machine could do. After coming from a Toshiba i3 with no graphics card, I was surprised to see that Starcarft II recommended I run the game in "low" settings.. I went to "can i run this" and tried a few games and noticed that the results were also poor. The site could not detect my graphics card.

    I asked a mate and he said to DL a benchmark test, I did and was only averaging 15 fps. his 2 year old pc was hitting 55 fps. So something was wrong.

    I called tech support, and got them to play around with it. we had issues updating the driver from the Dell website (there is nothing there to dl, he took a note of this), went to Nvidia site and downloaded from there, it said it wasnt compatiable with my driver.

    We also ran a few test with the Nvidia 3D settings, by adding programs to its program settings.


    but still, when I started games it wouldnt recongise the nvidia graphics cards. the tech guy offered a full refund, but asked if I'd wait and see what the Dell engineers could come up with and would call me back on monday (am waiting today for a phonecall).


    he also altered a few settings, but after the phonecall, I tried benchamrk again and now found it runs WORSE! 3fps!!!!


    (I am not sure if u can see that, but that is my results)


    I went to google for answers, and found links to a youtube clip, I tried this and found I could update the driver successfully through this guys advice.


    you can see my comments on the comments section. I again tried benchmark and the results are the same,


    I am running out of ideas and patience. my $2000 laptop is not doing what it says it can do!!! Hopefully some one on here has had the same issue, or has advice or something to make optimus work properly!


    here is all my benchmark results if the above link didnt work I used to be in the 5th coloum (6700+) when I first ran it




  • just an update.

    spoke to support again, sill not resolved. hes going to look into it....

    they have 1 week to fix or I returning it.

    in regards to games. it appears Shogun 2 is not recommended by nvidia. ok fair enough....

    still dont understand why its choosing intel over nvidia. given I bought this freaking laptop for that game.....

  • I just insalled the Dawn of War series. which is supported by Nvidia..

    they run fine. but is still not activating the Nvidia GPU!


  • I didn't try the links you posted so I may go over some of the same stuff.

    These would be my first basic steps, if something doesn't work the way I say, let me know exactly what does happen and we go from there.

    If you don't have the Optimus Tools yet, google this "/26992-optimus-test-tools-finally-in-users-hands" without quotes, then download the file that is linked.  There are two files one of them is NVIDIA Optimus GPU State Viewer, when you run it it updates every half second saying OFF, IDLE, or ON for the NVIDIA GPU.  This will tell you for sure if it is on or off.  

    I would probably go into the NVIDIA Control Panel and under 3D settings hit the Restore button to be safe, in  case anything got screwed up in your attempts so far to fix it.

    I would run the NVIDIA Optimus GPU State Viewer while testing to keep an eye on what is happening.

    You can try to force the game to run with the NVIDIA GPU by right clicking on the game icon and selecting "Run with graphics processor" then selecting "High Performance NVIDIA Graphics Processor".  Verify that the GPU turns ON when that program starts.  If it turns ON then try the game and see if you are having issues.  If you stil have issues with the game even though the card is ON I would think the issue is more on the game side than the machine. Hopefully forcing the GPU ON turns it on and makes the game run right, if it does then try running the game without right clicking and selecting the GPU.  If the GPU turns ON when forced but not when not forced then you have to make sure that for that game in the NVIDIA Control Panel the GPU is set to NVIDIA Control Panel.

    The most important thing to know is whether the GPU is actually turning ON, not just whether the game recognizes it.

    Let me know how this stuff works. We can do more troubleshooting once I know more about what is happening.

  • If you right click on an icon for a game or program you should get a "Run with graphics processor" option selecting that will give you two more options.  If you don't have that option I don't know what to tell you other than to try to uninstall everything dealing with nvidia that you can, only reinstall stuff from dell.

  • I have had posts deleted by a mod. I am not sure why tbh..

    is it possible to send my laptop back and get a Raedon card put in?

  • or, how do I rest the bios?

    a few other forums have mentioned that

  • They only offer the one card for the m14x from what I know, with either 1.5 or 3 gigs of ram for the card so I doubt you could have a different one put in by them, probably couldn't find another that fit either.

    I know you had a double post on this forum, maybe one got deleted, I think there are issues with links inside a post or abusive language and stuff like that.  I don't know why your posts would have gotten deleted except for something like that.

    Did you find the Optimus Tools?

    Do you have the "Run with graphics processor" option when you right click on an icon?

  • by "rest" the bios, I assume you mean reset or restore.  Restart the computer right away it will say "hit f2 to enter setup", in the bottom right corner.  If you hit it at the right time you will enter the bios setup screen.  Hit the right arrow and you should move along the menus at the top of the screen, when you get to exit you can hit the down arrow until you highlight "load optimal values" or something like that.  Hit enter it will ask if you are sure say yes.  Then hit the up arrow until you are on "save and exit" hit enter again.  It will restart and windows should load.  You just reset the bios to Alienware defaults.

  • well.

    Dell are sending a technictian out on monday to fix my issues.

    I even bought SSF4AE (which is fully supported by Nvidia Optimus) and it still doesnt select the graphics card.

    As for questions above.

    No, I dont have the run with graphics option on right click.

    I have optimus tools, it always says its off, it goes to "idle", when I change a setting, but then reverts back to off a second later

    I havent done the bios thing yet, I'll let the techs do all that.

    I just really wanna play shogun 2 lol

  • It's odd you don't have the graphics option on right click.  Have you tried updating software / drivers from Dell?    I am currently running the latest NVIDIA driver on my machine.  It works fine.  

    Alienware 13 - i5-4210U - 16 GB MEM - 512 GB SSD  - 2 GB NVIDIA GeForce GTX 860M



  • when I first had the problems, I treid to download/update the Dell drivers. it would only give me a 10kb file.

    I then called tech support and they tried it, and same thing. a 10kb file. its a driver mangaer, but not actually a driver.

    so they took note of it..

    yes the right click to run would be most helpful!!!

  • Hopefully you get it figured out.  A few people have had issues no one has ever said they don't have the right click option.

  • hey guys just an update.

    on monday I had a dell techy come out and look at the laptop, he did a few things, then decided to change the mother board.

    works like a charm, kinda...

    SSF4AE runs at 69+ frames a second, same goes for SC2.

    Shogun 2 runs alot better, but it wont select direct x 11. i can benchmark it on 11, but not run it... odd..

    I can now right click and run a program using the nvidia graphics option.

    am tempted to update my driver from the dell one, but figure it may get worse.

    also, when i run Benchamrk, it still runs bad. even if I select the nvidia option.. also odd.

    it also takes alot longer to boot up (alot longer)

    anyway, my 2k laptop works now.

  • Glad to hear laptop works now B3

    Alienware 13 - i5-4210U - 16 GB MEM - 512 GB SSD  - 2 GB NVIDIA GeForce GTX 860M