Transparent bar at the top of my screen. M14x - Alienware Forum - Alienware Club - Dell Community

Transparent bar at the top of my screen. M14x

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Transparent bar at the top of my screen. M14x

  • Here is a description as best as I can make it :

    I received my M14x today and promptly set myself to set it up. From the start though I noticed there is an linear area at the top of my screen (~5milimeters)  that is transparent and will now allow any window to fill the entire screen, leaving me with a small portion of my desktop any time I have a window maximized. The mouse can also go in it freely, which makes closing a window a pain because I have the habit of dragging my mouse to the top-right corner and simply clicking but now since this bar is in place my mouse uselessly clicks in this blank space giving me the context menu of the desktop. 

    Solutions I tried : 

    - I installed the newest drivers from Intel for the integrated graphics card and the newest drivers from nVidia for the GPU. The results were interesting, each time I installed new drivers the transparent bar would make way for the windows once again. But when a UAC prompt goes up, the bar places itself back at my screen and I have to reboot if I want to make it go away.

    - Checking in every control center I could think of, nVidia, Intel, Alienware and no option came up as to how to get rid of that.

    - Changing the resolution did nothing


    So here I am, posting here in hopes someone would have the answer. It's not a terrible bug but it's displeasing. Help ? 


    Picture : Heres a picture of my screen

  • Well my problem is solved. I screwed around a bit and managed to see that a process named Toaster was using my GPU so I investigated it. Upon killing the process the top bar disappeared. Toaster.exe is a process ( from what I can make of) of AlienRespawn, from the name I suppose it's job is to make place on the screen ready to post messages ("toasts") and show them onscreen. As this may be undesirable I suggest to KILL THE PROCESS. UNLESS you plan on using AlienRespawn a lot. 

  • You could have pressed F11 on your keyboard and you would have had a full screen.

  • Meh, the only programs I like fullscreen is games. The rest of applications I like them well maximized and showing my toolbar with any overlay I may have.

  • The same problem is present on the M18x. Pressing F11 does not correct it. I'll try killing Toaster.

    If this suggestion answers your question or leads to a solution, please click the green "Yes" button in the bottom of this post. 

  • Perfect fix .  Unless you are about to recover your system I can't think of a reason this would need to be running.


  • I had this problem too, and if it's a dell issue, then perhaps everyone has this annoying inability to maximize their windows.  My solution involved disabling a startup program:

    This is caused by a process called toaster.exe. This process belongs to Dell DataSafe Local Backup. One simple way is to uninstall this software. But it seems that this software is integrated into Dell factory image restore, I am not sure it is safe to uninstall. I checked the startup service shown in the msconfig, and found a familiar name, which is SoftThinks Agent Service.SoftThinks is the software vendor who provides this problematic software. So here is the way to get rid of the process toaster.exe:

       Open control panel

       Double click on the ‘Administrative Tools’

       Double clikc on the ‘Services’

       Scroll down and find the ‘SoftThinks Agent Service’, change the startup type to ‘Disabled’, and then click ‘OK’.

       Restart your computer, problem solved ;).