M17x R3 - hard disk port 0 / 1 certified for SATA III 6Gb/s ? - Alienware Forum - Alienware Club - Dell Community

M17x R3 - hard disk port 0 / 1 certified for SATA III 6Gb/s ?

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

M17x R3 - hard disk port 0 / 1 certified for SATA III 6Gb/s ?

  • Hi, 

    I am an m17x R3 owner and want to use 2 OCZ Vertex 3 120gb SATA III 6Gb/s SSDs in both my hard disk bays. But I have read at so many places and seen in benchmarks that in m17x R3 sometimes (randomly) the port (module) 0 or 1 start showing SATA rate as 3Gb/s where as the SSD has 6Gb/s and other times it shows correct 6Gb/s. The transfer rates are also affected when this happens.

    May be this is a BIOS issue but i have the stock laptop as it came from the factory. Could DELL please look into this ? It's not just me a lot of owners are reporting this. 

    One very credible source of reports is www.notebookreviews.com. Please see this post http://forum.notebookreview.com/alienware-m17x/576313-m17x-r3-port-0-true-always-sata-6gb-s.html and I am looking for some solution from dell.


    Thanks & Kind Regards, 


  • Hi,

    This occurs because the driver "Storage Technology Intel ® Rapid" does not correctly detect the SSD Sata III, as OCZ Vertex 3 or Intel 510.

    The solution is the following:

    1) Set AHCI in BIOS as hard disk options

    2) Install Windos 7. and let windows install the native AHCI driver.

     Windows will automatically recognize it is a SSD hard drive and then Windows 7 to correctly configure the SSD (TRIM, defragmentation, PREFETCH, SuperFetch ...).

    3) If you run a benchmark program. You will see that  the reading is 450 Mb/s minimum. This is typically a SSD Vertex 3 connected to a SATA 3


  • @ Alfred,

    my name is derick and i also have an m17x R3 and recently purchased an intel 510 250gb ssd, but after (and not over the top here) but possibly 15 clean installs in every which combination i still cant get my ssd to be my boot drive and a secondary(original) 750gb drive to be my data disk, i am having so much difficutly with this and even worse is as we all know ssd's arent cheap so im worried maybe im doing something wrong would you kindly be able to maybe give me a step by step instruction on how to overcome this, also my ssd is in port 1 the middle port and my bios is set to raid (as iv read that intel recommends raid over ahci)

    thank you in advance greatly appreciate you taking the time to read my case

  • EDIT: also should i be trying to instal windows 7 in a AHCI configuration or a RAID0 configuration?, i havnt tried AHCI yet jst due to being a little worried i  might do something irreversable but ye,...also i do have the intel rapid sotrage driver on a USB stick which i use right!!!before the win 7 installs(you know when it asks for hdd drivers and such) thanx again

  • Hi derickkk, I actually came here to find out about my SSD clocking down to 3GBps instead of 6GBps (as reported by the Intel Rapid Storage Technology app)..I'll be trying the AHCI tonight and see if it makes any changes..

    I was having similar problems like you..Let me confirm..Your windows keep dropping to two options asking if you want to recover or launch windows and no matter what you select, it keeps looping this..Correct?

    I had this problem and overcomed it the hard way..The problem actually starts occurring once you install the "OSD Application". If you dont install it, the problem will not occur. Something might be wrong there. I have excluded it and it working perfectly fine now. Thought I'd share with the community.

    I'll try the AHCI over RAID tonight and see if there is any problem (and if it works with the OSD in AHCI)..Cheers

  • I'm bitterly disappointed at DELL support, after I reported this same problem re: port 0 transfer speed dropping from SATA 3 to SATA 2 they came back to me and stated their database said my M18x only support SATA 2.

    I've pointed out that on the specifications page (62) on the mobile manual it clearly states support for SATA 3.

    Given the length of time this has gone on I'd expect they aren't interested in getting this fixed.

    Very dissapointed given I've forked out about £2K for the M18x.


  • Hi All ,

    All of you in this thread are more experienced than I am . I just go an OCZ vertex 3 90GB  SSD (SATA3) and my other disk is a HDD. I was wondering if any of you could suggest on which HDD bay (0 or 1) do install the SSD and HDD.? According to what Ii understood (Leo Heart's post) there is a problem with the speeds dropping from SATA3 to SATA2 only when TWO SSD's are plugged in simultaneously and NOT ONE...Correct?


    Your help will be much appreciated


  • Actually the problem is with the bay0. For some reasons, if you use the HDD in bay0, you will have problems. Plug the SSD in bay1, and the normal HDD in bay0. The problem of speed dropping is not because of two SSDs but rather the bay0 itself. Not sure about new motherboards though. Mine has been working perfectly since I changed the setup from bay0 to bay1.

    You may also want to try altering the AHCI vs RAID settings in the BIOS. For some reasons, my laptop had stalls while trying to boot Windows into it but has been working perfectly fine with RAID. Good Luck :)

  • This problem of lower speed SATA 3 is not a hardware problem. Is due to a software problem with the Intel driver. You must uninstall the Intel Rapid Storage and install the native AHCI Driver for Windows 7 then you can connect two devices Sata 3 and its speed is not affected. This is regardless of whether the discs are SSD or traditional disk HDD I have in my laptop Alienware M18, two SSD Vertex 3 installed and the speed is correct.

  • AlfredOle, I've actually tried that setup..Didn't help..Im on M17x though..

  • Hi All

    Thanks alot for your suggestions. I will be using only one SSD and one HDD. So placing the SSD in Bay 1 and HDD in bay 0 and performing a clean install of the OS on the SSD and booting up in AHCI should solve all problems for me..Correct?



  • Yes, you are right..