Alienware M15x Optical Drive Wont Eject/Freezing

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Alienware M15x Optical Drive Wont Eject/Freezing

  • Ok, so up until now, my M15x has been running like a champ. No problems at all.

    I had just added a new 256GB SSD for the laptop, and reinstalled Windows. Shortly after installing all the drivers and windows updates, I started to install COD MW2 on the machine. After the first disc finished, it asked me to insert the second disk. So I pressed the eject touch key on the touch strip, and to my surprise, the system froze for a good 10 seconds, then resumed, but the DVD did NOT eject at all. Thinking maybe it was just a glitch, I tried again.......and bam. The same thing happened. Froze for about 10 secs, then I could use it again. But the disc was still stuck.

    So I tried going to My computer and right clicking my optical drive to eject, and this time, I just got a continuous spinning circle trying to open the right click menu. The system then did not respond, and I pressed CTRL ALT DEL to shut it down from there. When I clicked shut down, it stayed there for 10 mins, when I realized that it wasnt going to shut down. So I did a hard shut down.

    I rebooted the PC, and while it was loading windows, I pressed eject and it worked. No problem. But as soon as I tried putting a disc in the drive again and ejecting while in Windows, the same thing happened. I tried this in safe mode, and I dont get the problem there, which leads me to believe its a driver problem, but I dont know where to begin? It does this with any kind of disc in the drive while loaded in Windows. I have installed windows on this machine plenty of times before without ever having this problem until now. I dont want to reinstall windows again yet, because I wanted to know if anyone else ever experienced this issue and had a fix. I dont really want to call Alienware because they are probably going to end up replacing some part with a tech and he will break my machine like last time. I dont want to go through that again. So if anyone can help its much appreciated.

    Specs:

    Core i7 720QM

    8GB DDR3 1333Mhz

    256GB Samsung SSD

    WIndows 7 Ultimate x64

    ATI Radeon HD 5850

    DVD/CD RW Drive


    The BIOS is the latest A07 and also running the latest Command Center with all the latest firmware, etc. Any help and input is appreciated. Thanks

    Alienware Aurora R4
    Intel Core i7 3930K
    16GB 2133MHz Corsair Dominator GT
    3GB AMD Radeon HD 7970
    SoundBlaster Recon3D Fatal1ty
    Killer 2100 NIC
    512GB Crucial M4 SSD
    19-in-1 Media Card Reader
    Blu-ray Disc Combo / DVDRW
    W7 Ultimate x64
    23" Samsung S23A750D 1080P 120Hz

  • Ok guys, I have even updated to BIOS A08, and I still have this problem. As of right now that I am typing this, I have a disc that is stuck in the drive. Same exact problem as before. Freezing and no eject.

    Is there a fix to this? Can anyone help? The laptop is only 3 months old and I dont want to have any parts replaced on this thing.

    Alienware Aurora R4
    Intel Core i7 3930K
    16GB 2133MHz Corsair Dominator GT
    3GB AMD Radeon HD 7970
    SoundBlaster Recon3D Fatal1ty
    Killer 2100 NIC
    512GB Crucial M4 SSD
    19-in-1 Media Card Reader
    Blu-ray Disc Combo / DVDRW
    W7 Ultimate x64
    23" Samsung S23A750D 1080P 120Hz

  • Good you posted under your old post, so we can see the history.

    I'm hesitant to reply because I don't have an AW laptop, but since no-one ever replied to your original post, maybe some of this might help ...

    If it's a removable or swappable drive, power-off and try removing and re-inserting the whole drive (to make sure it's making good contact) ... I've seen that fix laptop optical drives several times.

    There is usually a tiny emergency eject hole that you can use a straightened paper-clip in. Get the disc out before trying the next possible solution.

    Sometimes, you can delete the drive from the Device Manager and let it be re-detected and it will work better (that's an old Windows fix and it works).

    After a fresh reboot, see if the Eject option from Windows Explorer works. This might tell you if it's the OS or the touch-strip.

    Does the Touch-Strip have a driver or software that must be loaded in order for it to work?


    Alienware Aurora ~ Intel i7-930 ~ 12gb ram ~ AMD HD-5870
    256gb Samsung 830 SSD / 1tb HDD ~ LG Blu-Ray ~ USB 3.0 PCIe
    Dell 24" UltraSharp u2410 LCD ~ Dell 22" LCD

    All my Dell Machines and Specs

    Wiki-like Threads I've written and other Favorites

    Posting Tips:
    - Always provide machine make, model, specs and software versions.
    - Click the button if we answered your question.

    Registered Microsoft Partner
    & Apple Developer:

    Gaming when I'm not programming.

    I answer questions here, but
    I'm not a Dell employee.

  • Its not a removeable drive....well, it is, if I disassemble the entire laptop. That is the only way to get to it. Its connected by a single sata cable, which is securely conencted to the motherboard and optical drive. And the drive does not have any emergency eject holes.....its a slot load drive.

    I can eject the drive, but I have to hard shut down the machine and eject it once its booting up. I tried the device manager thing and its a no go. I just did a clean install of windows as well, more than once to try and resolve the issue. There is no software for the touch buttons that I know of.

    The problem only seems to happen if I leave the disc in there too long, i.e. installing a game, copying files, etc for 5+ minutes. If I just load in a disc, and eject it, it works fine.

    I had just installed Mass effect 2 on the system, and when it was done installing, the 2nd disc would not eject. I tried to eject it from My Computer, but as soon as I right clicked the drive, the system froze and I couldnt do a thing. It did this also with my MW2 discs...except that one happened after disc 1, and I couldnt go on to install disc 2, which caused a problem.

    I know the touch strip works fine because it reads everything when using the computer, even at the BIOS, I can see the touch button flash when i touch it.

    My previous M15x had this same issue, and they ended up replacing it with a brand new one, which is the one I am currently using. My old one was a lot more picky though......any disc i put into it immediately caused the issue no matter what.

    I just dont know if its a software problem or hardware problem, and if so, which is it? It doesnt seem like its hardware as the last one also had the issue, but I could be wrong. I paid quite a bit for this machine, and I love it, but seriously.....I thought the problems with the desktop were already enough. LOL.

    @ Chris, can someone in engineering look into this and figure out what is causing this problem? Does anyone else with an M15x/M17x have this issue at all?

    Alienware Aurora R4
    Intel Core i7 3930K
    16GB 2133MHz Corsair Dominator GT
    3GB AMD Radeon HD 7970
    SoundBlaster Recon3D Fatal1ty
    Killer 2100 NIC
    512GB Crucial M4 SSD
    19-in-1 Media Card Reader
    Blu-ray Disc Combo / DVDRW
    W7 Ultimate x64
    23" Samsung S23A750D 1080P 120Hz

  • Sounds like a bad drive (everything else has been eliminated). Flash the drive with the latest firmware. If that doesn't work, I would replace the drive and cable next.

    If it's slot-load, they might be locked into a specific drive from a specific OEM (choices are slim).

    I wonder if this person has a similar drive?

    http://en.community.dell.com/owners-club/alienware/f/3746/p/19347000/19757333.aspx#19757333

     


    Alienware Aurora ~ Intel i7-930 ~ 12gb ram ~ AMD HD-5870
    256gb Samsung 830 SSD / 1tb HDD ~ LG Blu-Ray ~ USB 3.0 PCIe
    Dell 24" UltraSharp u2410 LCD ~ Dell 22" LCD

    All my Dell Machines and Specs

    Wiki-like Threads I've written and other Favorites

    Posting Tips:
    - Always provide machine make, model, specs and software versions.
    - Click the button if we answered your question.

    Registered Microsoft Partner
    & Apple Developer:

    Gaming when I'm not programming.

    I answer questions here, but
    I'm not a Dell employee.

  • Also, if you have a DOS mode Diagnostics on your AW laptop ... test the drive. If it fails there, it will tell you a lot.


    Alienware Aurora ~ Intel i7-930 ~ 12gb ram ~ AMD HD-5870
    256gb Samsung 830 SSD / 1tb HDD ~ LG Blu-Ray ~ USB 3.0 PCIe
    Dell 24" UltraSharp u2410 LCD ~ Dell 22" LCD

    All my Dell Machines and Specs

    Wiki-like Threads I've written and other Favorites

    Posting Tips:
    - Always provide machine make, model, specs and software versions.
    - Click the button if we answered your question.

    Registered Microsoft Partner
    & Apple Developer:

    Gaming when I'm not programming.

    I answer questions here, but
    I'm not a Dell employee.

  • I ran the diagnostics, with no errors. My discs read real fast without problems. I can burn discs fine and read them fine.

    On my previous machine, I had the SATA cable, optical drive, and the motherboard replaced because of this issue, and the problem persisted. I think there is either a firmware problem, possibly with the drives or the motherboard, or its some sort of driver problem. I just have no clue anymore.

    I trust this notebook more than my desktop machine to be honest. I really hope they can shed some light on this.  I am thinking of getting the BDROM drive instead to see what happens.

    Also, if Chris can do some investigation in engineering or the labs that would be great. Because I know tech support is just going to replace the same 3 components and not solve the problem.

    Alienware Aurora R4
    Intel Core i7 3930K
    16GB 2133MHz Corsair Dominator GT
    3GB AMD Radeon HD 7970
    SoundBlaster Recon3D Fatal1ty
    Killer 2100 NIC
    512GB Crucial M4 SSD
    19-in-1 Media Card Reader
    Blu-ray Disc Combo / DVDRW
    W7 Ultimate x64
    23" Samsung S23A750D 1080P 120Hz

  • (1) One guy on another forum had the same issue on his M15x. While the PC was on, he turned it upside down so the keyboard faced the ground. Then turned the PC back over and pressed the Eject Touch Control button. The CD ejected
    (2) Others have said just a power off/on will unstick it
    (3)
    * Power off
    * Remove the battery and disconnect the power adapter
    * With those removed, press and hold the alienhead power button for 20 seconds
    * Put the battery and power adapter back in, turn on and try to press the Eject Touch Control button

    (Liaison for Desktops, Alienware, Monitors)
    Drivers
    Order Status

  • Big SmileI have tried the power draining to no fix.

    I dont know if this helps out at all in maybe improving anything, but since I have uninstalled the CC and OSD Utility, I have not had the eject problem. I am guessing its a software problem here. I just finished installing MW2 without having the freezing issue going to the second disk and ejecting it after install was completed. Also installed Mass Effect 1 without the freezing. Tesla had me thinking ever since he said touch button software.........so I immediately went for those 2 applications after I realized it. I guess I should say thank you.Big Smile

    And here I am, finally figuring out the problem, after multiple tech visits and part replacements, I lost my Nebula Red edition M15x notebook. When they exchanged my machine because of this problem, they ended up sending me a Cosmic Black model. I had paid extra for the Nebula Red...........but oh well. I doubt they can do anything now.

    Chris, can you have engineering take a look at that? My guess is that it was the OSD causing the issue. Maybe they can fix it? I dont really care much for the OSD, but just thought I would let someone know.

    Alienware Aurora R4
    Intel Core i7 3930K
    16GB 2133MHz Corsair Dominator GT
    3GB AMD Radeon HD 7970
    SoundBlaster Recon3D Fatal1ty
    Killer 2100 NIC
    512GB Crucial M4 SSD
    19-in-1 Media Card Reader
    Blu-ray Disc Combo / DVDRW
    W7 Ultimate x64
    23" Samsung S23A750D 1080P 120Hz

  • Good trouble-shooting on your part Methodical.

    If I helped, and pointed you in the right direction, I am glad to help.

    When I saw your post that the DOS level diags passed, I was getting ready to write a message telling you that we are back to a Windows software problem. You beat me to it. Smile

    After you work these kinds of problems for a while, you find it's not always to obvious choice (in this case the optical drive, or any hardware for that matter). And sometimes, you have to backup a few steps, (and find out what DOES work) before you can move forward to the solution.

    Since it's an intermittent problem (after prolonged use) Dell likely missed the software conflict. But this is how software gets fixed (and updates are released). Hopefully, Chris will forward this thread to the proper Dell engineering team so it can be fixed.


    Alienware Aurora ~ Intel i7-930 ~ 12gb ram ~ AMD HD-5870
    256gb Samsung 830 SSD / 1tb HDD ~ LG Blu-Ray ~ USB 3.0 PCIe
    Dell 24" UltraSharp u2410 LCD ~ Dell 22" LCD

    All my Dell Machines and Specs

    Wiki-like Threads I've written and other Favorites

    Posting Tips:
    - Always provide machine make, model, specs and software versions.
    - Click the button if we answered your question.

    Registered Microsoft Partner
    & Apple Developer:

    Gaming when I'm not programming.

    I answer questions here, but
    I'm not a Dell employee.

  • Thank you.

    I had this problem before, loading software from 3 DVD's. I couldn't afford to power off in the middle of the process. So I ended up starting again using an external DVD drive. However, this time, I used the turning laptop upside down trick, pressed eject and out cam the disc first time! Smashing!

    Regards

  • Great to hear this thread helped, thank you very much for the feedback, don't forget to check our support site for troubleshooting guides and common solutions:

    Alienware M15x: Troubleshooting Articles

    Alienware-Natalia
    Dell | Alienware Technical Support Alienware Arena
    #iwork4Dell
    Opening your case does not void your warranty! Check out Alienware Artificial Intelligence
    I can't always reply to PM's, if you need extra assistance visit: YouTube Logo Facebook Logo Twitter Logo