M17x - Wierd Issue with latest OSD & Command Center

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

M17x - Wierd Issue with latest OSD & Command Center

This question is not answered

Hopefully someone from Dell/Alienware has seen this and there is a solution...

After doing a clean install of Vista64 on my M17x, the OSD utility v2.21 (OSD_main.exe) for some reason will (about 90% of the time) fail to start at startup.  This basically prevents the Fn keys and OSD from functioning.  This problem doesn't occur until after you install the new Command Center (2.010).  If I then go into the OSD folder and manually double-click Launch.exe everything is happy again.

Finally became discouraged and decided to switch over to Win7.  Using same driver versions since their also the ones for Win7... Same issues there as well as random errors where AlienFX or AlienFusion is unable to startup at boot time (Only happens in Win7).

I've tried installing and reinstalling on both OS versions which hasn't made a difference. 

I'm at a loss here...  Does anyone from Dell or Alienware actually check these things to make sure they work BEFORE posting them to the website?  Just curiousAny help is appreciated...  I've spent two days fighting with this :(

- Denver

All Replies
  • Hi Denver,

    I had a similar problem with the OSD and Command Center before and after a Windows 7 reinstall.  The function keys did not operate, nor did items on the LCD touchpad, i.e. volume, wireless, command center or stealth.  The DVD operations continued to work on the LCD touchpad.  I called Alienware support regarding the stealth key, because at the time I wasn't sure how that selection functioned and I wanted to know if it would warn me I was entering stealth.  I was on the phone with the technician for many hours trying to get the Command Center to work with the OSD.  Finally, I gave up.  I now run my M17x without the command center and everything works fine.  If I want to change the light colors of my keyboard I will reinstall the command center, change the lights, and then uninstall the Command Center.

    My guess is the Command Center software is not quite working as intended lol.  I'm content to wait for a better version.  I don't use, nor did I ever intend to use the facial recognition software and I can set my power options via windows.

    I just wanted to let you know you're not alone :)  By the way, there's some great information to be had on the M17x problems and solutions over at the notebookreview forums in the alienware section.

    Edit:  In this post is a possible solution.  I'll give it a try.  http://en.community.dell.com/forums/t/19301615.aspx

    Alienware Area-51 | Bios Version A07 | CC 2.5.51.0, A07 | Windows 7 64 | Dual GTX 285 | Creative X-Fi | MS Habu mouse | Dell L100 keyboard

    Alienware M17x | Bios A02 | CC uninstalled | Windows 7 64 | Dual GTX 280M | IDT | MS Habu