Query about m17x, and switching graphics modes - Alienware Forum - Alienware Club - Dell Community

Query about m17x, and switching graphics modes

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Query about m17x, and switching graphics modes

This question is not answered

Hopefully that title is descriptive enough.

I'm  hoping someone can help me. I obtained my laptop on Friday and when I got it there was a small nvidia icon on the right side of the taskbar that would allow me to switch between discrete and integrated graphics modes. It was also there on Saturday when I installed windows messenger, office, and a couple of games.

As of allowing Vista(64) and mcaffe updates yesterday however, that icon has gone, and I can't work out how to get it back or how to switch between them any more. It may have had nothing to do with those updates of course, they were just what I allowed a couple of hours before I noticed the change.

The F7 function key also doesn't seem to do anything anymore (whereas before switching graphics modes would make the screen 'flash' once while it adjusted, or if I had mcaffee open at the time it would demand I close it first, it now does nothing).

In the meanwhile, going by my device manager which only has the Gforce 9400M G listed, I'm assuming I'm stuck in integrated mode. This doesn't change if I restart, and doesn't change if I set my power mode to high performance (which was my other hope), so I'm sorta stuck atm.

Does anyone have any suggestions on how I can get my graphics functionality back? :|

All Replies
  • Hi Ephidel

    Congrats on your purchase! Smile

    Off the top of my head - it could be one or more of the following :

    1. Check the Hybrid Graphics options in the BIOS (although installing McAfee or Updates shouldn't have done this) Check your manual for the difference between each of the settings. Some force Discrete Graphics on, others allow Hybrid & Discrete. (Also there is a new BIOS A01 available but remember to re-enable any RAID settings after if you have this configured first).
    2. This one caught me out - Are you in Stealth Mode by any chance? It's the top-right touch-button on your M17x that looks like a tachometer. When enabled, you should see it saying Full Power when you toggle it. This is separate to the Power Plan (High Performance).
    3. Check your graphics driver. Only 186.xx onwards support Hybrid configurations. I think the best one for now is 186.12 which is on the Dell site.

    Try this first and see if your icon re-appears. Hybrid gfx is clever in principle, but not as clever in execution it seems (at least for now).

    Bon chance!


  • Thank you Trelawney!

    I checked the stealth mode first as I could do that without restarting, and I hadn't hit that by mistake, but then I checked the bios as per your recommendation and it turned out that the Hybrid Graphics option had somehow disabled itself. Still not sure entirely how it did that, but I was able to re-enable it with no problems so now everything is working properly again, icons, function keys and all.

    Cheers for your assistance ^^

  • Coolio - glad to have helped, and thanks for letting us know!

    Enjoy! Geeked

  • hi Trelawney Hope, you sound like someone who KNOWS stuff!  I had pretty much the same problem.....I went into the BIOS and enabled DISCRETE GRAPHICS.  My problem is, after that my M17x doesnt boot to the desktop....all I get is a black screen with my mouse pointer moving around as i move the mouse!

    My problem all started when I booted into a desktop that was black with white and coloured horizontal lines flashing on and off.  I tried reinstalling graphics device drivers, no joy.  then i deleted EVERYTHING graphics related and reinstalled the GeForce 9400M G.  It doesn't show the two  GTX 260M though.  Thats when I went into the BIOS and they were turned off.....hope all this makes sense!  i TRIED emailing Dell but my reply seems to have got lost. The only thing I got was a questionairre in German asking id the service was good!


    Any ideas??

    Thanks in advance



  • Hi TwoBlokes

    Please try enabling HYBRID (i.e. both on-board and discrete gfx) and boot into Windows. Assuming this works ok - you will be running using the onboard 9400M graphics chip and default driver whilst doing basic desktop operations. The Discrete are the 260//280M which only kick-in when you play games, etc, unless you set them as default (always on). All other settings leave at page default.

    What you then need to do is download the latest drivers from nVidia (or Dell) and install these (I use the 195.81 Betas from nVidia). There will be a lot of flickering as the system switches between each of your cards, setting up the drivers, and you may need to reboot.

    Assuming this works on - try running a game to see if the DISCRETE (260/260M) kick in without issues. If you still wish to use these ALL the time, then you can go back into BIOS and disable HYBRID and force DISCRETE, but personally I think Hybrid works fine.

    Remember the golden rule. ALWAYS turn on your M17x with power lead (and switched on!), else you will get a warning message when you first boot. If this happens. Press F2 - Turn the power on and re-enable Hybrid Graphics again. I say in this order as if you just turn power on and continue - the M17x will only work with the onboard 9400M and won't 'see' the discrete when you go into games. A pain, but once you know the rules you know what to watch out for.

    Hope this helps!




  • Alienware M17x Graphics options

    The computer will have to be rebooted to switch from Integrated GPU to Discrete GPU or vice versa. The need for a reboot applies to all the cases listed in the table where Hybrid Graphics is off.
    Vista Hybrid On, Integrated Greyed Out = Discrete Nvidia 260M/280M or Integrated Nvidia 9400M
    Vista Hybrid Off, Integrated Off = Discrete AMD or Discrete Nvidia GTX 260M/280M
    Vista Hybrid Off, Integrated On = Integrated Nvidia 9400M
    XP Hybrid Off, Integrated Off = Discrete AMD or Discrete Nvidia GTX 260M/280M
    XP Hybrid Off, Integrated On = Integrated Nvidia 9400M

    Hybrid SLI Modes
    * Hybrid SLI is only supported on the Windows Vista operating system
    * Hybrid SLI is only supported with at least 256 MB dedicated memory for the mGPU
    * All displays must be attached to the mGPU for seamless mode switching
    * Hybrid SLI is only supported on OEM notebooks with specially developed software released for specific notebook configurations. Loading generic drivers on a Hybrid SLI notebook will cause hybrid features to disappear
    * The two operating modes of a Hybrid SLI-enabled notebook are:
    - Boost Performance Mode where the discrete GPU and system board GPU work collaboratively to provide higher performance
    - Save Power Mode where the Discrete GPU completely shuts off and the Integrated GPU renders and drives the display (HybridPower)

    Social Media Support
    Driver help & FAQs

  • Cheers Trelawney but min'es KNACKERED!  The engineer man replaced both graphics card and I STILL cant enable DISCRETE in the BIOS and boot up.  Seems its now a fault with the motherboard!  So, I wait til Monday and see what happens then!  Cheers for the help though....I'll keep it in mind if and when its fixed!#



  • Gosh - hope you get it fixed and are back up and running soon!

  • Perhaps the BIOS had disabled the RAID configuration that you had.  After a bios update, RAID needs to be re-enabled.