Alienware 18 and Windows 8.1 - Alienware Forum - Alienware Club - Dell Community

Alienware 18 and Windows 8.1

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Alienware 18 and Windows 8.1

This question is not answered

Hey everyone

Has anyone tried upgrading to Windows 8.1 on their Alienware 18?  Any issues?

All Replies
  • Hi Eggs1796,

    Alienware 18 is eligible for upgrade to Windows 8.1 Operating system. You may go ahead and upgrade the same. Please refer to the following link for upgrade instruction:

    Revert for further queries.

    Thanks and Regards,
    DELL-Sujatha K
    Dell Social Media and Community Professional
    Order Status
    Download Drivers

  • 8.1 will not install on my Alienware 18.  I have tried numerous times, but get the following message:

    Sorry we couldn't complete the update to Windows 8.1. We restored your previous version of Windows to this PC

    0x80073B92 - 0x2009

    I have searched endlessly and cannot get one explanation for this message.  Can you provide any assistance?


  • Do you have Alienware Respawn installed? If so, the version you have is probably incompatible and that may be what is causing the upgrade to fail. Uninstall Alienware Respawn and try again. If you haven't already done so, create Respawn media first, just in case you need it.

    If you have UEFI, GPT disks and you are using Legacy Option ROM, you may want to reconsider the option of moving to Windows 8.1 because you will have a watermark on your desktop as a constant reminder that "Secure Boot is not configured properly." You can eliminate this nasty Windows problem with a clean OS install to MBR disks and using Legacy Boot (not UEFI with Legacy Option ROM, but actual Legacy mode instead of UEFI).  

    If this suggestion answers your question or leads to a solution, please click the green "Yes" button in the bottom of this post. 

  • Respawn isn't installed.  My BIOS setup up is the following:

    Secure Boot <ENABLED>

    Load Legacy Option ROM <DISABLED>

    Boot List Option <UEFI>

    Secure Boot Mode <STANDARD>

    If I change it to the first option you have pictured above, how will this affect my system?  Will this require a complete reinstall?

    Thank you for your response.

  • I would recommend using what was shown in the image as a clean install. If your current Windows 8 setup is working properly and you are happy with it, no need to change it. If you want Secure Boot and have it enabled, then you will not have an issue with the watermark with Windows 8.1 once that is installed.

    Having Secure Boot enabled imposes restrictions on hardware, firmware and driver changes. Everything requires a signature, which prevents you for doing whatever you wish to do with your system and it is very anti-enthusiast. Average PC users that never do anything out of the ordinary will typically be oblivious to it.

    If you do not have Alienware Respawn installed, then that obviously is not preventing the Windows 8.1 update. I don't know what is preventing it otherwise. I do know that I was forced to install some Windows Updates to upgrade one of my systems to Windows 8.1 before it would allow the upgrade, but that does not appear to be the cause of your situation since the upgrade process begins, but rolls back to your previous version of Windows.

    After doing an in-place upgrade on my first system, I acquired a Windows 8 ISO and went back and did a clean install on all systems so I did not need to fuss with the Windows Store or Windows Updates.

    If you have done extensive tweaking of the Windows 8 UI as I have, there could be something with one of your system modifications that is halting the process. If you are running Windows 8 in its default form, then the upgrade failure is even more puzzling.

    If this suggestion answers your question or leads to a solution, please click the green "Yes" button in the bottom of this post. 

  • I agree, this is very puzzling indeed.  I have done 4 other 8.1 upgrades with no problems other than having to reinstall a couple of programs.  The last one was to my Alienware M17X and all went off without a hitch.  Then came the Alienware 18 debacle.  I thought it may have something to do with the SSD drive accelerator, so I even disabled that prior to one of the attempts...still no go!  In one forum post, one guy actually removed the accelerator drive and that was also unsuccessful.

    I have tweaked the UI a little, but nothing drastic.  The same tweaks were made to the M17X, so I don't believe that to be the issue either since that one upgraded just fine.

    Bottom line, there are many of us with this issue but no solutions.  I haven't seen the particular error code that I get on any of the other posts however, all of their error codes are slightly different and seem to refer to driver issues.  My system is completely up to date with all Windows updates and drivers from the Dell site.  I even updated the BIOS to A03 hoping that would make a difference, but it didn't.

    Thanks for trying to help me, and if you hear of any 'FIX', please pass it along to me.  I would like to get this upgraded, but doing a complete reinstall is really out of the question.  The system works just fine and I don't want to go back through the process of getting everything back the way I like it, and it doesn't guarantee that the upgrade will work after that!

  • Yes, definitely will alert you if I find out anything that may be helpful.

    I Googled your error code and got nothing as well.

    Another funny thing is that I can no longer download Windows 8.1 because my internet connection is not detected when trying to download it from any of my systems. WiFi or LAN, Windows firewall disabled, router firewall disabled, direct connection to PC to cable modem... nothing works... ever. Tried early morning, mid-day and near midnight and always the same thing. Thankfully, I have an ISO that I snagged before it got pulled from the web host, and I also have DVD installation media on order. But, that doesn't help the folks that do not.

    Not sure what changed. You would think Micro$oft would try to make it easy for customers to upgrade to their latest mess, but it is a real pain in the back side. It seems that a lot of folks are running into this snag, but there is no meaningful advice on the web about it.

    If this suggestion answers your question or leads to a solution, please click the green "Yes" button in the bottom of this post. 

  • I was able to find one post regarding that odd error code.  Apparently it has to do with the following:

    The requested system device cannot be identified due to multiple indistinguishable devices potentially matching the identification criteria.

    My system originally came with one HDD, and the accelerator SSD drive.  I added a second HDD for backup purposes and clone the C drive to the secondary drive on a daily basis just in case of failure.

    Based on another post I ran across with this same scenario, the user disconnected the second drive, then installed 8.1 successfully.  He did however have issues getting the second drive recognized after that.  He was able to get beyond that by uninstalling the rapid storage drivers and installing the latest version from intel.

    I have gone in and and disconnected my second drive and am in the process of attempting to install 8.1 again.  I will post my results whenever it is completed.

    In case I have the same issue with the rapid storage package, how do I uninstall those drivers?  I don't see it listed in device manager and the user did not indicate how he had done it.  Do you have any suggestions?


  • You uninstall those RST drivers in Control Panel > Programs and Features. However, before you do that, go into Intel Rapid Storage Technology and disable Acceleration and be sure the mSATA is reflected as available if you have that enabled. I may already be like that, just check to verify that is the case. You do not want to see the mSATA functions as part of a RAID0 membership. It should appear as a standalone drive in the RST Control Panel. If you do not verify that, your mSATA may become inaccessible to Windows after uninstalling the RST drivers. 

    Using GPT volumes instead of MBR and having Secure Boot enabled causes a lot of issues, including HDD and SSD not being detected even in the BIOS. That's why I use Legacy mode and MBR... it eliminates all that nonsense and provides a rock-solid experience.

    If this suggestion answers your question or leads to a solution, please click the green "Yes" button in the bottom of this post. 

  • I am happy to report that my attempt was successful.  However, once I reconnected my cloned drive Windows 8.1 didn't see it.  I then went to BIOS and confirmed that it was seen there.  I then pointed to it in BIOS and was able to boot into Windows 8 successfully from that cloned drive.  Windows 8 was able to see the other 8.1 drive as well.  My thinking was that if I can boot from it, once pointing back to the Windows 8.1 drive, perhaps it would be seen by that OS.  I went back into BIOS, pointed back to the 8.1 drive and booted in.  I was right, I was able to see the drive in My Computer as well as rapid storage.  This seems to have corrected the issue without having to uninstall and reinstall drivers thank goodness!

    I did however need to reinstall several programs as expected (THANKS A LOT MICROSOFT).  Please pass this along to any users with an Alienware 18 machine and dual drives where one drive is an exact clone.  Hopefully what I have gone through will help someone else.  Thank you again for your time and patience with this.

    Take care.