Alienware x51 Won't Boot - Dreaded "Internal Hard Disk Not Found" - Please Help

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Alienware x51 Won't Boot - Dreaded "Internal Hard Disk Not Found" - Please Help

This question is not answered

Hi,

To start off, I've loved my X51 for the ~3 months that I've had it, when it worked perfectly, so I hope somebody can help me on this issue :)

I bought the i5 X51 in early June with a GT545, 1TB hard drive, 8 GB ram, everything else standard. I've never installed any new drivers, or any OS, windows update is turned off, never replaced any parts or opened the case, etc. It's laid in the same place in my room since the day I've gotten it, essentially still in factory settings. I use it primarily to play games and it did that well enough, so I've never seen any need to do anything else. Games are pretty much the only thing I have installed on the computer besides basic office applications, and I haven't installed anything or changed any settings recently.

It worked perfectly until this morning - when I went to turn it on, it said "internal hard drive disk not found." I googled the issue from a laptop, found a couple threads on this forum and followed the suggestions, but nothing's helped so far:

- Tried booting from a Windows 7 CD, didn't help - I could get to the windows setup sceen but it doesn't see the hard drive.

- Pressed F2 at alienware splash screen, went to boot options, made sure it was on UEFI (it was), tried again and it didn't help, togged the setting to legacy and back to UEFI, still didn't work.

- Made sure it was set to boot from hard disk in the boot options screens, tried booting several times, still kicks me to the same "internal hard disk not found" screen. 

I would really, really appreciate it if anyone could advise me of additional options, or if any Dell/Alienware support could advise. Unfortunately I work a very demanding job as a corporate attorney, and the only real free time I have is one or two hours late at night every day, so my opportunities for live assistance (e.g. calling tech support on the phone while next to my computer, or getting a tech to actually come over) are extremely limited.

Thanks.

All Replies
  • jk15,

    Is it possible that the Dell software autoloaded the newer A06 bios? When you were in the Bios- Boot tab, was the Hard Disk Drive BBS Priorities set to Hard Disk Drive?

    (Liaison for Desktops, Alienware, Monitors)
    Quick link for Manuals and Drivers

  • Hi Chris, I'm not home from work right now so I can't check the BIOS version, but in the BIOS boot tab, there's no option for "Hard Disk Drive BBS Priorities" at the bottom of the list in the boot options screen, because it doesn't seem to see that there's a hard disk there in the first place. In the list of boot options, the entry just says the generic "Hard Disk", but it doesn't actually read the name of the disk like it's supposed to.

    For reading around on the forum, I know there's a separate workaround where if you install the new A06 Bios and it doesn't boot, you go to boot options and change the entry from "Disabled" to "Hard Disk" but that doesn't seem to be the case here. It doesn't see any hard disk, so it doesn't give me the option to select Hard Disk Drive BBS Priorities.

  • I've just checked, and it is still BIOS A-03. I tried pressing F5 at the flash screen to enter diagnostics, and that screen could not find the hard drive either.

  • Ok. Power off. Disconnect the power cord. Open the case cover. Disconnect/reconnect the cables in between the motherboard and the hard disk drive. Close the cover. Reconnect the power cord. Power the system on.

    (Liaison for Desktops, Alienware, Monitors)
    Quick link for Manuals and Drivers

  • Tried - still the same problem. Don't have another hard drive or tower I can use to diagnose the problem - is it possible to get a tech sent sometime on the weekend?

  • Just to update (since Dell never replied to this thread), after several phone calls with Dell support, they sent a tech over to take a look at the computer. He ended up replacing both the motherboard and harddrive, so I'm up and running again.

    I'm still not sure why my relatively new X51 would be fine one night and then completely out of the commission the next morning, but I guess these things happen. It's a bit troubling there wasn't an easier solution, but in either case, it's fixed now, so all I can do is cross my fingers and hope it doesn't happen again.