Trouble upgrading Aurora-R3 memory. - Alienware Forum - Alienware Club - Dell Community

Trouble upgrading Aurora-R3 memory.

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Trouble upgrading Aurora-R3 memory.

  • Purchased last year with 12GB (240pin DDR3 SDRAM 1333Mhz), needing to upgrade to 16GB by replacing 2x2GB with 2x4GB.

    Tried purchasing two different name brands of memory locally that meet this specification.

    I don't get a BIOS message, beeps, anything.

    Bought Dell certified (Kingston) - "we charge more, but it's guaranteed to work".

    Same result.

    Put the 2x2GB back in, and they still work just fine.

    Web searches indicated that XMP should be disabled in the BIOS, but I don't seem to have anything that looks like that.

    (Have DRAM Timing Mode=Auto, Advanced DRAM Configuration, and DDR Memory Voltage=Auto.The Advanced DRAM Configuration has a bunch of sub-settings, which probably won't be compatible with two sources of memory).

    Motherboard = Alienware 046MHW

    BIOS = A06

    Trying here first, then make the call to technical support.


  • These are the memory specifications for that platform.

    Memory module connectors Four internally-accessible DDR3 DIMM sockets
    Memory module capacities 1 GB, 2 GB and 4 GB
    Memory type 1333 MHz, 1600 MHz XMP or 1866 MHz XMP
    Minimum memory 2 GB
    Maximum memory 16 GB (1333 MHz) or 16 GB (1600 MHz XMP) or 16 GB(1866 XMP)

    You need to make sure that the 4 of them are the same ones and should be working at the same speed.

    Dell | Alienware Technical Support Alienware Arena
    Opening your case and/or replacing parts yourself does not void your warranty!
    YouTube Logo Check out our disassemble videos on YouTube
    If you need extra assistance please use Facebook Logo Twitter Logo, I can't always reply to PM's