CPU + memory upgrade for Alienware m15x - Alienware Forum - Alienware Club - Dell Community

CPU + memory upgrade for Alienware m15x

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

CPU + memory upgrade for Alienware m15x

  • Hi, I have an Alienware m15x (core i5 540M, GTX-260M, 4Gb 1333Mhz RAM).

    I would like to upgrade the CPU and memory, which processors will fit in the socket and what type and how large memory does my machine support?

    I have experience with building desktop PCs, but its been a while and have never upgraded a laptop before.

  • The m15x will accept any of the following processors: i7 740QM, 840QM and 940XM

    It accepts up to 16GB of ram, though be advised that the BIOS might not correctly display 8GB blocks (but they'll still work and Windows identifies them just fine). 2x4 GB (1333 MHz, PC-10600) is a great and very cheap upgrade!

    The 840QM is a very affordable upgrade, especially if snacked off ebay. The 940XM can be a but draining on the 150W power limit on the m15x.

  • Thanks so much. I mainly run Linux, I assume it will also correctly detect 16Gb of mem.

  • Oh and thanks for the ebay tip, found an 840qm from what looks like a reputable seller for around 1/3rd the price of the same part elsewhere. I figure its probably not a new cpu, but we'll see how it goes.

    Looking it up on Intel's site it says it only supports 8Gb of mem, and since 16Gb is pretty pricey I'll just stick with that.

  • A thank you to the people who helped me here and just a quick update with some notes for other people wanting to perform the same operation.

    I got a cheap new (tray packaging instead of retail) core i7 840qm off a reputable seller on ebay ($200 instead of the 3 times as much online retailers like tigerdirect wanted) and I just finished installing it, I also got 2x4Gb corsair "vengeance" 1600mhz mem (yes I know it will only run 1333mhz) and everything seems to run fine. The memory did not register correctly with my old cpu, but with this one it reports the correct speed.

    There is a teardown video in 3 parts on youtube (search "m15x teardown"). Its important to notice that the indicator panel above the keyboard needs to come off to unscrew the air vent or you won't be able to get the heatsink/fan assembly out. Also always use an antistatic connection to equalize the potential between yourself and the laptop at all times, since the case is metal and has unpainted parts inside, this is easy.

    I installed the cpu with some EVGA thermal paste and I tried rendering a demanding scene with the Blender 3d application under linux and the temperature of all cores stayed around 75 degrees C for the 11 minutes it took to render. The same scene on my old cpu took 16 minutes, so its a good speed bump. The exhaust air gets pretty hot, which to me means the thermal paste and heatsink is doing its job. I learned from desktop systems that too much thermal grease is not better, you want as thin of a layer as possible while still making contact between the cpu and the heatsink. The cores are now idling at just below 50C.

    The memeory also got a good deal faster (tested with mbw under linux), presumably because this cpu can run the memory at 1333mhz vs. the old which ran it at 1066mhz.

    Lets see if it keeps running under load longer than the 11 minutes before. I also need to test games to stress the graphics adaptor along with the cpu to see if the power brick can keep up.

    Thanks again.

  • Update 2:

    Ubuntu 11.04 runs fine, but the GTX-260M will only run at powerlevel 1 (275/301/550mhz). The CPU goes as fast as it can and Ubuntu doesn't crash even when I'm running the system hard.

    Windows 7 is quite unhappy. The moment I install Nvidia drivers I can only get to the login prompt, beyond that it freezes, and with a high performance profile it might not even get that far with flickering and lockups during boot. With the generic microsoft VGA driver it works fine, however this is useless for games.

    At this point I'm assuming my power supply simply can't provide enough power or I somehow messed up my GTX-260M. Fan is running, etc.

    Considering the m15x has a reputation for being underpowered in the larger configurations, I'm banking on the former and ordered the 240watt PSU for the m17x and a 9 cell battery. I guess it'll be more money out the window if that doesn't work :(

    Option after that is taking the heatsink off my gfx card and apply some better thermal paste as well as reseat the card in the slot.

    Last resort is to go back to my original CPU.

    Will continue to update this thread so other people will have a chance at deciding if they think this is worth it. If I can get it stable and working in windows it definitely will be for me. Might even consider a bigger gfx card if I decide I have enough power to run it.

  • This is not a power issue - the power draw of the 840QM CPU isn't higher than what it can take. It sounds more like your system is stuck in Stealth mode or if Windows is set to it's power saving profile (no idea if Ubuntu has anything comparable).

    How are you trying to make it enter P0? by starting a game?

    This forum: forum.notebookreview.com/alienware-m15x has significantly more insight into the m15x than this one board - so I'd recommend that you look around there, and post there, if you don't find anything at first hand.

  • Oh, sorry didn't read that you had the W7 driver issues... Just for the hell of it, try to power drain the system. Some times that solves the strangest issues:

    1) Shut down the system

    2) Remove the battery

    3) Hold the power button (alien head) for ~15 seconds

    4) Reattach battery

    5) Power on the system

    You're saying that Ubuntu has no problem running the GPU?

  • Ubuntu can run the GPU, but its stuck on powerlevel 1 (0 is lowest power, 3 is highest).

    Windows can't even log in with the nvidia driver running (tried older driver, newest and latest beta, same result), but in safe mode I tried to set a high power profile and it didn't change the power level Ubuntu was able to run the GPU at. I also toggled the stealth mode button on and off a lot before booting, etc.

    Windows gave me a couple of BSODs while logging in (most of the time it freezes) saying it timed out waiting for an interrupt on a secondary core, however the CPU runs just fine under Ubuntu at full tilt and in windows 7 safe mode. My logic with the power was that it might prioritize the power of the CPU over the GPU. Of course I could just have a semi-dead graphics card.

    I will try to completely drain the power as you said. I already tried to reset the bios without luck.

  • for windows 7  since it dont specify is it original install or is it a *CLEAN FRESH* install

    Alienware X51 R3  

    Intel i7-6700k  32gb ram
    NVIDIA GTX-1070 FE 

    Inspiron 11 Flip , Studio 1535 ,Inspiron 6400

    Previous Systems:

    M18X R2, M17X R2 ,M17X R1, XPS M1730 & M1530, Inspiron 17R

    Posting Tips:
    - Always provide machine make, model, specs and software versions.
    - Click the button if we answered your question.

    I answer questions here, but
    I'm not a Dell employee.

  • Sorry, first it was the original install, and I tried doing a fresh install as well. Same problem.

  • I tried holding the power button for half a minute without any power sources, didn't change anything :(

    I know the CPU and GPU I have should do alright on the stock power brick, but I still have a tiny hope it will make a difference to get a larger one.

    As I said, I doubt its the new CPU, I think I would have seen more crashes and I doubt my issues would be related to my Nvidia driver.

    I could possibly reflash the bios and reseat the graphics card. All that will have to wait a while though.

  • Continuing the thread here:   forum.notebookreview.com/.../643345-problems-after-upgrading-i7-840qm.html

  • I also run Linux on my M15X it recognized and I am using Komputerbay 8GBX2 =16GB memory modules with no problems at all.