Alienware Alien FX message - Alienware Forum - Alienware Club - Dell Community

Alienware Alien FX message

Alienware Club

Alienware Club
Share your Alienware experiences and join in the conversation with other Alienware users.

Alienware Alien FX message

  • For the last few days, every time I boot my Airea 51 ALX  I get the following message:

    "AlienFX will not monitor events and will only desplay the Default event on your system. However AlienFX will display 3rd party lighting effects.

    To enable events monitoring click Enable Alienware AlienFX Events".

    Other than months ago setting a different colour for the PC and the Mouse, I have never done/programmed anything in AlienFX. Only now have I even opened it again in order to find a solution.  

    I found on a hidden icon "Alienware AlienFX (Disabled mode)" on the Taskbar. Rightclicking this Icon opens the Alienware AlienFX Editor with the following lines  Go Dark - Quick Change - Enable 3rd party Alien FX Access (which has a tickmark).and Exit, but nowhere could I find any help or tutorials for "Enable Alienware Alien FX Events".   Advanced Settings have never been used [probably the reason the Icon states (Disabled mode)]. 

    Removing the tickmark from the "Enable 3rd party....." line has no effect, the notification still appears upon reboot, thus I put it back.. Looking into the Event Viewer I couldn't see anything there either. (N.B. On Oct 30 I applied a few Windows updates, but believe this message did not start right after those updates but two days later. Not certain though.)

    Rick Dewas in your comment on the update to the latest CC version (I am still using - maybe I need to update now after all) "After boot, I then use the fix I found to get "events" to work."  Did you have the same problem I am only now experience?  If so what is the fix you found?

    Rick can you or anyone  put me into the right direction to get rid of this notification?


  • Bump

    Can anyone tell me how I can get rid of the below shown notification at each boot-up?


  • Never mind - Fixed the problem by way of using a month-old Acronis Image, then re-installing every update as I had done since that date.  The reported message at each boot-up is gone.  Don't know what made it suddenly appear. Only used basic software I use everday. Obviously wasn't an update.

    Sill don't know what kind of Events monitoring AlienFX "is" and then "was not" monitoring.  But am curious to find out.


  • For information and if someone has more input I would appreaciate it.

    When testing an IE9 problem and using the recently installed Acronis 2012 upgrade which has the additional Tool "try&decide".  I noted just when clicking on this tool without even starting it that pesky message re-appears at each boot.  So presumably i may have well after installation once clicked on this tool.

    I will report this to Acronis - so "hopefully" they and Dell/Alienware can find a solution as if I have to re-install an image to get rid of it I might as well not even use the otherwise very good tool for testing software or whatever and take an immage beforere-install an image instead.afterwards which is a lot more work.


    • if anyone knows how to get rid of this message any other way, I would like to know
    • if anyone knows where I can "click "Enable Alienware Alien FX Events, I would like to know (presumable that would be one way of fixing it.)
    • If anyone knows what type of events Alien FX is no longer monitoring, out of curiosity, I would like to know.(ac

    actual Alien FX message  message posted earlier.



  • Acronics 2011 has Try and Decide as well.

    When you open T/D on the bottom there is the link to restore previous state or apply changes. Don't know that much abot T/D. Next time you open it instead of cancelling out select discard changes.

    Just a suggestion, not sure if that is the issue or not.


    "Choosing Apply changes will allow you to keep the changes made to the system, and choosing Discard changes will return your system to the state it was in before turning on the Try&Decide"

  • Thanks AAA737flyer

    Never saw T/D on 2011 LOL.

    Anyway, the problem re the Alien F/X message starts after just opening the T/D menu from the main Acronis menu  without actually starting T/D so the T/D system has not run and nothing was done to be discarded. Thereafter this message appears after each boot.  And if I actually run it and then select discard,  all is back as it should be except for the pesky Alien F/X message.  

    However, I will test your suggestion to use "discard" even though T/D had actually been started. as soon as my next Image is created as re-installing an image so far has been the only way to get rid of this message (which, btw. is somewhat greak to me as a) I don't know what events F/X is "normaly" monitoring and b) there is no such an "Enable........" to click in Alien F/X)  At that time I will report results too, I'm not holding my breath, though given that after actually running T/D and using discard this message stays anyway.


  • The enable function I think you are referring to is on the Alienware FX editor. If you look at the tray table, a green Alienware icon should be present. There it allows you to enable or disable third party access to AlienFX. You need to right click on the icon to see the menue. From there you can enable or disable 3rd party access.

  • Thanks again,

    The only item listed under Edit is Theme Tempo.

    If I click on Advance, it opens a 3 line (tray?) at the botton but I do not see a green Alienware Icon. I tried to right click on anything but didn't get a menu. BTW, I have so far not set up any programmes under FX.  It came with plain blue setting, my wife liked purple so I set the PC itself to purple. So the green icon perhaps shows up under the latest CC version, I have and have not updated so far, perhaps I should, but normally I follow the rule "if it works, don't fix it"  The missing menu  could also be due to not having any programs set up, thus no need to turn on or off.  This is way over my head even after watching the videos.

    I now assume "events" are related to any Applications added to F/X and stated actions, say Email and having told F/X to do something with lights when say an e-mail arrives being thus an event it would monitor.  Not having done so, so far, and presently not even thought about, the "non-monitoring" should thus be of no concern to me, just the sudden annoing pop-up. So if my assumption is correct, perhaps  Try&Decide is able to tell F/X to turn off monitoring (perhaps due to cases where someone has set up an "event" for something one should not do when running under T/D) and if so perhaps it does it  too early, i.e. before even starting the service and hence doesn't enable it again when stopping T/D.

    Will be interesting to read what Acronis is going to say about this.  I found their e-mail support to questions and follow-up excellent.  AW could learn from this.


  • I'm referring to the bottom right section of your W7.


    Regardless of the color, the Alienhead can be right clicked to enable or disable AlienFX access

    I tried snipping a picture of it. Hopefully it will appear when I post.

  • Thanks for you perseverance in helpen me.

    I found that Icon (was set as hidden on my site) before - see my original message where I said:

    "I found on a hidden icon "Alienware AlienFX (Disabled mode)" on the Taskbar. Rightclicking this Icon opens the Alienware AlienFX Editor with the following lines  Go Dark - Quick Change - Enable 3rd party Alien FX Access (which has a tickmark).and Exit, but nowhere could I find any help or tutorials for "Enable Alienware Alien FX Events".   Advanced Settings have never been used [probably the reason the Icon states (Disabled mode)]. "

    As said clicking "Enable 3rd party......" is not the same wording as in the message and in any event didn't change anything. Not sure I tried a re-boot - will do now.  HOWEVER,

    Looking at the icon it now reads "Alienware Alien FX:Alienware.ath"  So Try&Decide must initiate the (Disabled mode) designation and hence the pesky notice at each boot.  But from that menu (have tried everything) there is no way to togle from/to disabled mode.  I would bet there is a "1" or "0" somewhere in the registry.  Will look for it.  May be that is what Rick Dewas did in fixing this, assuming he was referring to the same problem. But one shouldn't have to go into the registry to "Enable" it.  There should be somewhare in AlienFX a spost for a tickmark reading "Enable Alienware AlienFX Events"  A serach in the Help section was also unsuccessful. The other line would tend to be related but when the Icon showed disabled, that line was ticked, just as it is now . And why would they use different wording in the message v/s the menu? That would be rather poor.


  • Further to the above I rebooted with the tick mark OFF, No message appeared. So that's not it.  However, which that off, it may prevent T/D from making this (permanent) change.  Perhaps setting that icon to "hide icon and notification" will eliminate that message, but that's not a fix but only a hiding the problem from view.


  • Ok, below is the "fix" I stumbled accross and additional information.

    First of all early this morning I trying to test this further, I opened "Try&Decide" (T&D) from Acronis again and it again (now for the 3rd time changed AilienFX to "disabled"

    Looking again into the Help menu of AlienFX.  A search for that qouted line did NOT find anything (perhaps my spelling error) but manually reading through many sections it it mentions that on the ICON on the right side on your Task Bar (may be a hidden icon) when right clicking it, it would give  the "Disable Alienware AlienFX Events" or " Enable Alienware AlienFX Events" line. Well mine certainly does not

    I tried the "Go Dark" line and as stated all my lights went off. However, the icon name now changed from "Alienware AlienFX (Disabled) to "Alianware Alien FX (Go Dark mode)".

    Clicking now on "Go Light" the lights came back on and the Icon name changed now to "Alienware AlienFX (Alienware ath)   No more "Disabled" and hence no more pesky notice when booting.

    So... if other run into this problem (see below!) - above is the two click fix.


    1. Later to-day AlienFX had gone into "disabled" mode without my opening T&D.  Only used E-mail, the Internet, Excel and WordPerfect so not sure what initiated this change.  I fixed it in the manner outlined above.
    2. I then opened T&D again BUT this time it did NOT change AlienFX to disabled.  Three times it did it, now it did NOT.  A Mistery!!.

    There must be a gremlin in my system (Norton states no virus). Perhaps my Alienware Keybord? But why no such problem for almost a year?  Whatever, problable I never find out., but know of a fix other then having to instal a previous Acronis image.

    AS to my  AlienFX menu not having that line outlined in the Help section, perhaps because I have not set up any events in the first place., i.e. just like the line changes from Go Dark to Go Lite, that missing line appears after setting up an event.. 


  • Hey thanks for checking that out. I tried it they way you did, go dark and then go light. Now the icon has green eyes again and it is not saying it is diabled. Thanks!

  • I had the same problem with that disable mode and the message that appeared at every reboot. I was able to fix it with the Go Dark and Go light solution. Thanks for your help. 

  • Go Dark and Go light worked for me too.