External SATA Port Multiplier Box 1-to-5 SATA2 Port Multiplier - New to the Community Forum - New to the Community - Dell Community

External SATA Port Multiplier Box 1-to-5 SATA2 Port Multiplier

New to the Community

New to the Community
Having trouble deciding where to post? Get tips and recommendations here.

External SATA Port Multiplier Box 1-to-5 SATA2 Port Multiplier

  • I bought this External SATA Port Multiplier Box 1-to-5 SATA2 Port Multiplier so that I could hook the single eSATA port on the back of my new Dell XPS 420 to it and thus obtain 5 eSATA ports. Unfortunately, the drives so connected do not show up in explorer. I contacted the manufacturer of this sSATA hub and they told me to find out if Dell machines support eSATA Port Multiplier. In effect they told me this:

    "sounds like your computer esata port is not port multiplier compatible, please check with Dell for compatibility for SATA II spec and port multiplier enabled host port"

    IIs there a way to find out if the corresponding host controller supports port multipliers?

    I would really appreciate finding a solution to my problem.

    Than you very much for your help.

  • Giftmugsman,

    Found this in the XPS 420 FAQ:

    eSata port not working
    * Go into the BIOS and record you current Raid, HDD settings, Overclock settings, and enabled/disabled integrated devices. Once recorded, restart into windows
    * Load the A06 BIOS and restart the PC
    * Load the Intel Matrix Storage Manager driver
    * Load the Intel Matrix Storage Manager Application
    * Click Start- Turn Off Computer- Restart
    * Always backup your registry before editing.
    * Disconnect the device from the eSata port
    * Click Start- Run
    * Type regedit
    * Click OK
    * Navigate to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Iastor or IastorV
    * Click in the right pane with the right mouse button on Start
    * Click Modify
    * Change the Value data from X to 0
    * Click OK
    * Close the Registry Editor
    * Click Start- Turn Off Computer- Restart
    * Press F2 to enter the BIOS Setup
    - Set External SATA is set to On
    - Set SATA Operation setting to RAID ON
    * Exit the BIOS saving changes
    * Save and Exit
    * Once into Windows, all of your drives will be redetected by Windows
    * Click Start- Turn Off Computer- Restart
    * Once back into Windows, reconnect the device to the eSata port

    Hope this info helps get your multiplier box working

    Tony


  • Thank you very much for your quick response and information on how to get my e-SATA hub to work as it should on my brand new XPS 420.

    I  followed your instruction (with the help of a Dell tech) but where not able to have the eSATA hub recognized by the computer.
    The e-sata port would easily recognize a single eSATA drive, just not the 5-port Hub.

    The Hub manufacturer  -  http://www.sataport.com  -  wanted to know if this XPS 420's esata port is port multiplier compatible. I checked with Dell to find out  if the eSATA controller used in the computer is compatible with SATA II spec and a port multiplier enabled host port. Unfortunately I have not yet been able to obtain this technical information and hope that somehow a solution to the problem will be found.

    Again, many thanks for your help and I look forward with great interest to solving this puzzle.

    Roland

  • Thanks to SmoothSL for posting this in other forums.

    Instructions to turn on RAID and to use the eSata port on your XPS 420

    Please backup anything you don't want to lose.. I've done this process twice now and have had no problem with either.. This is from a end user and not from Dell, please understand that.... If you have success with this process, please post and let others know so they will not fear this process..

    -Download & Open R165147.EXE from dells driver page in the SATA Drives section.. The one that says Intel - Driver Applies to: Matrix Storage Manager

    -Open Control Panel

    -Double Click IDE ATA/ATAPI controllers

    -Right Click Intel(R) ICH9 2 port Serial ATA Storage Controller 2

    -Chose Update Driver Software

    -Chose "Browse My Computer for driver software"

    -Chose "Let me pick from a list of device drivers on my computer"

    -Click "Have Disk"

    -Click "Browse"

    -Find the folder you extracted the files from R165147.EXE

    -Chose "iaahci.inf" and select open

    -Click "OK" at the "Install From Disk" screen

    -Scroll all the way to the bottom of the drivers list and select Intel(R) ICH9 SATA AHCI Controller and click Next

    -You will get a driver warning, click Yes to continue

    -Vista will install the driver and tell you that you have successfully updated the driver software

    -Click Close and follow the same steps to update the driver for the Intel(R) ICH9 4 port Serial ATA Storage Controller 1

    -Vista will prompt you to restart.. Click Yes and be ready to enter the BIOS by pressing F2.. (If you do not do this, Vista will give you a blue screen and reboot.. Don't sweat it, simply go into the BIOS and change it as stated below and continue. When you reboot Vista will prompt it did not start correctly before.. Select Boot Normally and continue..)

    -Change your SATA Operation from "RAID Autodetect / ATA" to "RAID On".. You will get a prompt stating you may be required to reinstall your operating system, highlight accept and hit enter..

    -Hit ESC and select Save/Exit...

    Your system will reboot and will load the "correct" drivers for Vista which will require one last reboot...

     

     

  • Hello gopimanne,

    Thank you very much for your post about my problems getting my eSata port to work on my DELL XPS 420.

    I had hoped that DELL would provide defining help on this topic but this was not to be.... a lot of chat but no
    concrete results at all. But you took the time and effort and posted your suggestions in order to help me out.

    Since I am more than a bit concerned and worried abut my new XPS 420 Vista - this model did not turn out to be as good a
    purchase as previous DELL computers I had bought in the past - and had hoped that all ports would work as
    they should, I still need a bit or reassurance that your proposed procedure will indeed fix my problem.

    My computer has RAID already turned on and if I follow your suggestions would this impact my present
    data, or is the driver up-date you suggest just that: a driver update that will fix my problems? I would be a shame if
    after the update my machine would no longer start up. Also,would a Restore Point be of any help for this
    upgrade?  You mention that you had performed this operation two times already with no problems.

    I would really appreciate receiving your comments as you're the only source of information and help I have
    received so far...and I am wondering where is DELL in all of this?

    Again, many thanks for your help.

    Smile

  • Did you ever determine whether the Dell XPS 420 has eSATA port multiplier support?

     

    - Bruce A. Johnson in Hardisty, Alberta, Canada


  • No, I have not been able to determine whether my brand new Dell XPS 420 actually supports and responds to an eSATA port multiplier, or if my particular DELL  XPS 420 machine is the exception.

    All efforts I made did not make my External SATA Port Multiplier box to respond and supply working ports. After the lengthy chat I had with Dell and the various postings here, I am not sure if DELL is even interested in looking into this problem.Even for a brand new computer.

    In the meantime I use USB ports and now I am running out of drive letters, too, as I have reached the last letter, namely Z.

     


     

  • I too have a Dell XPS 420.  I was looking to buy an external dual hard drive enclosure that connects up with eSATA.  The system requirements say, "For eSATA, the System Must Support Port Multiplier (PM) specifications."

    Since my computer is still on warranty, I called Dell Support to try to get some answers.  Surprisingly, I did.  It took some effort and patience on my part to direct the CS guy in the right direction, since he had never heard of eSATA port multiplying.

    He eventually found that both the current XPS 430 (which I helped my Dad order this week), and the older XPS 420, specify with regards to the eSATA port that it supports up to 5 SATA/eSATA drives through port multiplying.

    The CS guy could find nothing specific about how to get the port multiplying to work, just that for the eSATA to work, RAID has to be enabled in the BIOS.  He figured that it as long as the eSATA port was working at all, that it should also work with port multiplying.  I mentioned your problem, and he had no idea what to do about it.

    He DID mention that there previously were problems with SATA in general with the XPS 420, but that those problems were corrected with the latest version of the BIOS.  I checked it out, and found that the latest version is A06 (dated 2008-Jul-28).  Since the version on my computer was A04, I updated it.

    If you haven't already, then update your BIOS.

    I guess I'm going to take the chance on the dual hard drive enclosure I have my eye on, and hope there are no problems with it on my XPS 420.

    - Bruce A. Johnson in Hardisty, Alberta, Canada


  • I received my external dual hard drive enclosure, and both my XPS 420, and the new XPS 430 (bought by my Dad), have problems with it.  They will only recognize one of the SATA ports.

    The first time I plugged the device in, Intel Matrix Storage Manager has a popup, saying:

    "Storage Device Connected: A storage device was connected.  If this device is a port multiplier, only port 0 of the port multiplier will be active."

    I'm going to call Dell Support again, and make sure they also look at this thread.

     

    - Bruce A. Johnson in Hardisty, Alberta, Canada


  • It's been a long few hours talking to 5 different Dell support people on the phone.  Transfer, transfer, transfer repeatedly.  Explaining the issue repeatedly, even repeatedly to each person.  No one could help.  I'm amazed that I had so much patience (they may not agree, but at least I didn't give up until they did).  The last Dell support person I talked to (XPS support), elevated my case to Level 3 technicians, who will call me in a few days.

    The link to this forum thread has been added to my case, so the Level 3 technicians should read this.  Hopefully they read it before they call me.  I was requested to add any other information to this thread that would help them solve this issue.

    The case number addresses my Dell XPS 420, but the issue is also present with my father's brand new Dell XPS 430 (just received last week).  With both computers, the eSATA port will not support port multiplying, even though the specifications say they should.

    My computer is a Dell XPS 420
    Windows Vista Home Premium with Service Pack 1, 32 bit.
    Device Manager: Storage controller:
        Intel(R) ICH8R/ICH9R SATA RAID Controller
            Driver Provider: Intel
            Driver Date: 2007-Sep-29
            Driver Version: 7.8.0.1012

    My father's brand new Dell XPS 430 (received last week)
    Windows Vista Home Premium with Service Pack 1, 64 bit.
    Device Manager: Storage controller:
        Intel(R) ICH8R/ICH9R/ICH10R SATA RAID Controller
            Driver Provider: Intel
            Driver Date: 2008-Apr-15
            Driver Version: 8.0.0.1039

    When I told both computers to update these drivers, I got the result that they are already the latest versions.

    In the BIOS for both computers, the eSATA port is enabled, and RAID is turned on.  These are the default settings thankfully.

    Quoting from the Intel website: http://www.intel.com/design/chipsets/matrixstorage_sb.htm

    "Intel® ICH10R, ICH9R, ICH9DO:
    Six port SATA controller with RAID, eSATA, and port multiplier support, providing storage benefits of Intel® Matrix Storage Technology, Intel® Rapid Recover Technology, and Intel® Turbo Memory"

    Now, before you Dell technicians automatically blame the particular device I'm using to make use of eSATA port replication, hopefully you have read the rest of this forum thread.  I'm not the only person with this problem.

    Since you will want to know anyway, the device I'm using is:
    Vantec NexStar Dual Bay Hard Drive Dock
    Model: NST-D200SU
    http://www.vantecusa.com/

    When connected to the eSATA port, only the front SATA slot/connection works, the other does not.  It also can be connected to a computer using USB, which I have done to confirm that both of the SATA hard drive slots work fine.  I put in a 250 MB drive and a 500 MB drive, both of which have no problems, and are well below the limit of 1.5 TB allowed for each slot/connection.

    Listed among the system requirements for this device is:
    "For eSATA, the system must support Port Multiplier (PM) specifications for dual hard drives."


    Since I was told by Dell support technician "Jose" on 2009-Apr-16 that the eSATA port supports up to 5 SATA/eSATA devices through port replication (on both the XPS 420 and XPS 430), there should be no problem.

    Problem there is.

    Did I leave anything out?

    - Bruce A. Johnson in Hardisty, Alberta, Canada


  • Hello Windrider6

    Thank you for your postings about the problems and solutions you encounter about the External SATA2 Port Multiplier and the time you took to explain the difficulties you encounter with your two DELL XPS computers.

    I know and share your frustration fully, as I went through the very same process you did and I have nothing to show for it...except frustration and still more frustrations.

    My efforts where fruitless and the problem still exists on my DELL XPS 420 machine and this is why I mentioned in one of my first posts that:  "...I am wondering where is DELL in all of this? " 

    Contacting the manufacturer about this "birth defect" of  my XPS 420 was an exercise in futility and, like in my case, the tech support people had to consult a lot internally but never offered a solution. Maybe they still do not know what we're talking about.

    ./.

  • I haven't given up yet, despite the level 3 technicians not calling me yet.

    To Dell technicians: To reiterate, you can telephone me between the hours of 1 pm to 6 pm MDT (13:00 to 18:00, -0600 GMT/UTC).  Do not call before 1 pm.

    To see my current date & time, look at my main webpage (URL is in my signature below). 

    2009-May-05 Edit.  I took my homepage link out of my signature because Dell seems to think that it is advertising.

    - Bruce A. Johnson in Hardisty, Alberta, Canada


  • It's been almost six weeks, and no response from Dell.

    - Bruce A. Johnson in Hardisty, Alberta, Canada


  • I had hoped that a solution had been found as I'm still not able to get mine to work and am not able to find any help at all, other than this Dell Support Forum,

    .Crying

  • Consider using a hardware port multiplier solution instead of the software raid implementation of SATA controllers and port multipliers using Silicon Image chips. A 4x1 eSATA/USB Hardware Port Multiplier (HPM) that is OS independent and will work with any eSATA port is an alternative solution. The 4-port SATA integrated HPM with an Oxford OXUFS936QSE chipset uses hardware raid technology.

    RAID mode selection is done using a rotary switch and setup is completed by pressing a raid setting button. Once configured all is needed is to connect the HPM to your system via USB 2.0 or eSATA and detect, partition & mount the RAID volume.

    RAID mode supported are FAST2 (2 drive RAID 0 Striping),, SAFE2 (RAID1 Mirroring), SAFE FAST (RAID 1+0 Mirrored Stripped), BIG 2 (2 drives Concatenation), FAST4 (4 drive RAID 0 Striping), BIG 4(4 drives Concatenation), RAID 1+0, RAID 5 over 4 drives, or RAID 5+S.

    Connecting the HPM to onboard SATA ports on the motherboard is possible by using 2 eSATA ports PCI slot mounting bracket with two eSATA connectors to convert internal Serial ATA to eSATA.

    2TB, 3TB, 4TB, 6TB & 8TB Turnkey RAID solutions utilizing the 4x1 eSATA/USB Hardware Port Multiplier (HPM) are available at
    https://www.theraidbox.com

    The way software RAID works using SI controllers and port multipliers (PM) is that, you use the SATARAID5 array manager installed in Windows to see and configure as a raid volume all 5 drives connected to the PM. If the PM is connected to non-PM aware controller card (legacy) it will only detect one drive out of the 5.

    But using a Hardware Port Multiplier which uses an integrated hardware controller, the raid setup is done on the HPM itself. So once you connect it to a SATA port, it will be seen as a single RAID volume.