Forums

Gaming

Gaming
An online group dedicated to connecting gamers of all levels -- especially levels you've beaten. Noobs welcome.

Alienware TactX Headset and the Creative Sound Blaster X-Fi Titanium

  • The Alienware TactX Headset is not functioning with this Card.  First off the Microphone connector (pink) needs to be input into a blue jack.  When I have the microphone selected from the Creative Audio Control (FlexiJack, Microphone) I hear myself through the speakers and/or the headset earphones.  I have been trying to get this resolved for over a week. I purchased this system  for MMORPGs.  Now I can't voice within  raids.  I have tried the drivers from Creative and spent over 3hrs on the phone with Tech Support with no resolution.

    The TactX Headset is supposed to be plug and play and it obviously isn't.  So what do I do now?  I just want my Headset to work properly.  I hear the sounds great I mean it really sounds good, but why will the microphone not work?  To add insult to injury, Windows 7 Troubleshooting says there isn't a microphone connected, and then I tried to get a new driver which i believe addresses the issue (just appeared today) and it tells me I do not have Windows 7 as an operating system.  Major Bummer.

     

    I am reposting here hoping someone can help me because I can't hear my enemies coming if all I hear is my breathing :(

  • I have 2 Creative Sound Blaster X-Fi Titanium cards in 2 of my 6 computers and I have noticed that in order to get speakers/headsets/etc to work you can not follow what they say about installation/placement of plugs. The Speakers will not work in the green L/R speaker plug they must be in the Side L/R plug and it is the only one they work out of. For headphones....forget it..I replaced them with a USB Creative Sound Blaster Sound Arena Headset...by passed the sound card and they work great!!!!