W3000 picture issue - has anyone fixed successfully?

Digital Entertainment

Digital Entertainment
A space to talk about music, movies and other entertaining diversions.

W3000 picture issue - has anyone fixed successfully?

  • I've been reading many posts on various sites about the same issue I have been having with my Dell w3000 for years now (have to turn tv on and off many times to get picture to show up - green light and audio are not a problem and always work).  While I am not holding my breath for an out of warranty replacement TV after reading posts to this forum based on Dell's lack of a clear remedy for the issue both in a customer service sense and just at the very least helping people get a fix to the problem, it seems as if there have been many possible solutions.  The ones that sound most reliable are replacing the inverter (http://www.lcdparts.net/LCDTVInverterdetail.aspx?InverterOriginal=6632L-0048), replacing/fixing the logic board (http://www.lcdrepair.us/w3000-logic.html), or replacing the power supply board.  These options cost around the same amount and although the TV might not be worth as much anymore, I am still committed to fixing it as I have no other issues with picture quality, etc.  Could anyone help me figure out which part to by? 

     Additionally, I’ve always had this TV hooked up to an HDTV cable box.  I know it sounds strange, but I usually keep the display stretched so that non-HD channels fill up the entire screen.  In the past few months, after unplugging the tv and plugging it back in again to move the set, I am no longer able to “stretch” the screen.  When the input source for the TV is set to HDTV, the menu items to change the display size are grayed out – I can switch to a different input and change the picture, but once I go back to HDTV to pick up the cable, the size reverts back and I get black rectangles on the left and right side of the tv for non-HD channels.  I am positive that it used to work previously, could you advise if there is any way to fix this?

     

    Thanks so much in advance!

  • The problem with no picture started with my first W3000 about a month out of warranty.  Contacted Dell after putting up with having to turn the set on and off about a dozen times before getting a picture and they offered immediately to replace the set at no cost to me with a rebuilt W3000 which turned up on my doorstep 2nd day following, I just put the old set in the same box and called a 1-800 number and they took the old set away, great!  However after about a month the same problem started again.  I put up with it for about a year, called Dell to see if they could direct me to a repair facility and was told that I was on my own!

    From searching the WEB it seemed clear that the problem was in the inverter boards and I ordered a pair from lcdparts.net, installed them yesterday and lo and behold, I still have the same problem.  Searching further lcdrepair.us seems to think the problem is in the logic board and they offer a repair service wherein you send in your board, they repair it and send it back.  For me that means no TV for about 2 months return shipping time, much $$$$ and no guarantee that it is not the power supply or the lamp.

    For the mean time, we've resorted to to leaving the set on and just turning off the cable box.  Perhaps there's a new set in our future!

  • I have the same problem and it's getting progresively worse, to the point where I sometimes give up trying to get it to come on.  My problems started about a year after I bought it, so no warrantee solution (based on other posts, that may not have helped anyway). 

    I have been looking for a repair solution, but based on the numerous posts out there, it appears there is not a clear solution.  I saw a post where Dell recommends DecisionOne, but that appears to be about a $500-$600 repair and I would be better off buying new in that case (can get 32 inch sets in the $600 to $700 range these days).  Has anyone had any luck with www.lcdrepair.us solution.  Thier site indicates $149 to repair the logic board.  I tried calling them, but get a full mailbox message and then a hang-up.

    To any Dell folks listening....Shame on you for not owning up to this problem.  I have encountered numerous posts about this problem.  It seems the least that could be done is to facilitate a reasonable path to repair these sets (not the $600 DecisionOne path).  For what its worth, I have purchased my last Dell (anything).  After sinking $1300 into this TV and not having any reasonable recourse to fix a known problem (since at least 2005), I choose not to invest in your company and associated products.