Chrome OS Wi-Fi Support Running on a Mini 10v... Source Code Available

Chrome OS Wi-Fi Support Running on a Mini 10v... Source Code Available


The Official Dell Corporate Blog

Chrome OS Wi-Fi Support Running on a Mini 10v... Source Code Available

Last week, Google released ChromiumOS to the open source community at  ChromiumOS is a small, optimized OS whose purpose is to make it extremely simple and easy to browse the web.  Without a network connection, ChromiumOS is not very interesting. With a network connection, ChromiumOS shines.  The Chromium browser is extremely fast and makes for a great web-centric browsing experience.  Boot time appears quick too - about 12 seconds from hitting the power button.

Me and some other Dell folks noticed that Engadget recently got the Chrome OS running on a Vostro A860 netbook. I've been doing some timkering over the lat few days working to get our Dell Mini 10v up and running with ChromiumOS. As of late yesterday, I can report success.   

I have released an USB key image file to: The file name is: "ChromiumOS_Mini10v_Nov25.img."  It contains a functioning image of my USB key loaded with ChromiumOS.  In addition, I have made a best effort attempt to get the Broadcom Wi-Fi adapter working in this image.  It's definitely not perfect (read: highly experimental, untested, unstable, yada yada...) but it does appear to function.

Here are the caveats:

  • It will take more than 5-10 *minutes* for the ChromiumOS network connection manager to "see" the access points and allow you to select and connect - be patient.
  • Wired connections appear to work fine and appear quick to connect.
  • There are currently issues with both the connection manager as well as the underlying components (wpa_supplicant) that can easily break or get hung. When in doubt, reboot and give it another try.
  • Use this image at your own risk - it comes to you totally unsupported and very minimally tested.

Speaking of which, to "reboot" the image, you have to press the "power" key on the Mini 10v - there is no "reboot/shutdown" menu option to do this.

To copy onto an USB key (8GB minimum), find another Linux machine and utilize the "dd" command to put the image onto the USB key.

Example: dd if=ChromiumOS_Mini10v_Nov25.img of=/dev/sdb  

In this example, /dev/sdb is my entire USB key... use "fdisk -l" to see how your USB key is named for your particular environment. Be careful to select your USB device (again, use fdisk -l to double verify and confirm the correct device filename) and not another device... 

Some additional notes for the released image:

  • The user name to login is "dell". The desktop login window will complete the user name by adding "" to the end
  • The user password is "dell"
  • The root password is set to "dell"
  • I've included a script in /etc called "" to allow root (or sudo) to remount the root partition for updates/changes/whatever you like.

Obviously, this image comes with absolutely no support of any kind and is to be considered highly experimental and completely unstable. 

There are some good developer forums at for more information - for the chromium-os-development forum, I've posted a summary of what I had to do to get the wifi to the current working state. Much more needs to be done, but, for now, it's a start.



To post a comment login or create an account

Comment Reminder

Unrelated comments or requests for service will be unpublished. Please post your technical questions in the Support Forums or for direct assistance contact Dell Customer Service or Dell Technical Support.. All comments must adhere to the Dell Community Terms of Use.

  • Hi,


    Good job! Thanks :)


    Any chance you could upload a compressed version of the image?


    Thanks in advance!

  • There's a nice little python script for writing .img files to a USB drive at ( It might be safer than dd. It's under the linux directions for installing moblin to a USB drive.

  • I second this request. I'm at 0.5 GB of the 7.5 GB with ~17 hours left to completion. Not exactly magical! The download is averaging 120 kB/s, do you guys have a faster server to put this on?

  • Yes, slow down load.  I used one of the other downloads that was bit-toreented and installed on my M2300 with no problem, except for Wi-Fi.  Hope this works.  Does the build include OpenOffice... that would be great... then could edit Word files....

  • Any kind of mirror would be great at this point.. I've got 4 days remaining on a download I started this morning. Could someone that already has it put up a torrent perhaps?

  • I tried to download the file and had to go shave again, several times.  ZZZzzz...

  • Where is this torrent your speak of?

  • This is the link to the other torrent I mentioned:



    This downloads fast, but no WiFi.  If I had the time I would cook up a version with WiFi and OpenOffice, then we would be in business.  I bet we will be there in less than 7 days....

  • Hey Doug,

    Wouldn't it be great if it was possible to run Chromium OS off the Latitude ON device? I know the current 7.5GB version won't fit, but overall it's a match made in heaven:

    * there will eventually be an ARM release of Chrome OS

    * Chrome OS is meant for web apps only, and thus light not too CPU intensive apps (and the OMAP3 is pretty good anyways)

    * the Chrome OS team is working hard on making it boot in a second, so it will also be an "instant on" OS

    And this would mean that you can have upwards of 10 hours battery on Chrome OS, wireless connection included! 


    I can only hope you guys will include the Latitude ON on the next XT series tablet. I have the XT (first release) and I totally love it! Good job!


  • Very cool!  I look forward to seeing this continued to be developed. 

    Question, will this image work on my Dell Mini 9?


  • ok i got it and it worked ok, i booted my mini 9, waited approx 5 minutes, wifi started working, but no dns...and could not connect to anywhere even by using ip.

  • Glad someone downloaded it.  Mine timed out after 3 days at 5.7GB over Thanksgiving weekend!  At work I have a very fast pipe and it downloads at the same speed as at home, max 80k/sec.  ETA 1-2 days.  I have to try to build from scratch.

  • What I cannot understand about Chrome, and this is probably the wrong place to ask, is how you see the file system.  At least then you could get to the settings for WiFi. 

  • Here's a torrent I uploaded, since this download itook me at least a couple days.

    It's my first time uploading a torrent so if I made a stupid mistake let me know.

  • Thanks for doing this, should make things a bit easier.

    A massive thanks to Doug who was done the work, so we don't have to :)

  • jerryyyyy, ctrl-alt-t brings up the terminal.

  • Thank you, Doug!

    I understand this is an "unofficial" participation by Dell.  I look forward to more of the same, as well as official Dell cooperation with Chrome OS.



  • if any of you need support forums, I found a really good upcoming Chrome OS site here: Smile


  • We have removed the original 7.6GB .img file, and replaced it with a bzip2-compressed copy of the same, at only 900MB.  You will need to decompress it before writing it to a USB key.  There is also a README.txt file posted with instructions for how to uncompress this file.

    This should speed up downloads for everyone.


  • There is now an even smaller (302MB) and "better" image (I'll leave it for Doug to describe) which fixes DHCP as well.  Please download that image instead.    file   ChromiumOS_Mini10v_Nov30.img.gz


  • Well, the good news is all this downloaded real fast,  The bad news is I cannot get a terminal windows with <ctrl>t.  I am running on a M2300.  The WiFi is common, so was hoping it would work.  This always is a pain in Linux. 


    The <ctrl>t opens up a new window in the browser.


    Why can't you just run Ubuntu and the browser? 



  • The console terminal comes up when you type Control/Alt/T, hope that helps.



  • Thanks.  I got the terminal window opened and followed all the commands.  Unfortunately the WiFi does not turn on.  I assume on the Mini you have the little indicator in the upper right corner showing WiFi on (mine is off and I cannot turn on). Ethernet works fine in this little box.

    The problem may be that Ubuntu does not support my WiFi card:  the Intel 4965AGN.  I have used fedora 11 on this machine and it supports that card out of the box, but SuSe does not.  I have Ubuntu running on my M2300 in a Sun Virtual machine and seems I may be able to configure WiFi, but this is always an adventure in Linux. 

    I guess I could test further (there should be a generic solution for all the cards in the Dells).  Is there a way to download and use the Chrome browser as used in Chromium to my regular Ubuntu install?  I could debug this way.


  • Any possibility that Dell Mini 10 with poulsbo will have a chance with Chrome OS any time soon?

  • This apparently works to some degree with the Mini.  I see from a Dell ad I got yesterday they have the "11" on Sale for Xmas.  This does not work for WiFi on my Dell M2300.