Not all functions working after upgrade - BB Custom Topics A - D - Big Brother - Dell Community

Not all functions working after upgrade

Big Brother

Big Brother
Access more than 800 custom test extensions to share or use in resolving your IT challenges.

Not all functions working after upgrade

This question has been answered by robert.croteau
12-21-2011 11-09-52 AM.jpg

I just recently upgraded my server from 4.2 to 4.6. Things work for the most part, but some of the functions don't work

The check mark in the upper left corner now has a drop down box. Most of the functions in that menu work but a few don't.

"Check Config Files" does not work. When I select it I get: "show: File specified not found".

I see that bb-show.sh is calling bb-check.html. Okay, so I look for bb-check.html and see that it is called bb-check.html.DIST. Okay, so I rename it to bb-check-html. Still can't find the specific file. I review bb-check.html and see that it's calling bb-dochkcfg.sh. So, I look for bb-dochkcfg.sh and see that it is named bb-dochkcfg.sh.DIST. So I rename it to bb-dochkcfg.sh. I verify that the group and owner are set correctly and that the permissions are set correctly, but still "show: File specified not found" I also made sure that the $BBHOME varible is set correctly.

Okay, so now I'm wondering why these functions are not working? Any suggestions?

Thanks

Daryl

Verified Answer
  • Does the "check config" task appear in the page after you clicked the checkmark?

    yes, I'd rerun install/bbconfig from the 4.60 directory tree.

All Replies
  • in what OS platform are you upgrading on?

  • also, what happens if you click on the checkmark (and not one of the choices from the drop down box)?

    Do you still get and "show: ..." error?

    Files should have been renamed during the installation or copied to the cgi-bin directory of the web server.

    in the cgi-bin of the web server, what output do you get with?

    grep -n CONTE *show*

    it should return something like:

    bb-show.sh:33:if [ "$CONTENT_LENGTH" != "" -a "$CONTENT_LENGTH" -gt 0 ]

    is that what you get?

  • Robert-Andre,

    Thank you for the reply.

    I am using Solaris 10.

    The check mark only gets me the ack/manage/contact/edit page, just like what I expected to see in 4.2.

    Yes, my grep returns: bb-show.sh:33:if [ "$CONTENT_LENGTH" != "" -a "$CONTENT_LENGTH" -gt 0 ]

    You mentioned that the install should have renamed the files or copied them to the cgi-bin directory, but apparently that did not happen. Would you suggest a fresh install?

    Thanks.

    Daryl


  • Does the "check config" task appear in the page after you clicked the checkmark?

    yes, I'd rerun install/bbconfig from the 4.60 directory tree.

  • That resolved my issue, thank you.

    The upgrade section in the get started guide did not mention that I would have to run the install/bbconfig, so that did not get accomplished. Once I ran that, everything works as expected.

    Thank you.

    Daryl