Error thrown when enabling disk checking on RHEL 5.6 - BB Custom Topics A - D - Big Brother - Dell Community

Error thrown when enabling disk checking on RHEL 5.6

Big Brother

Big Brother
Access more than 800 custom test extensions to share or use in resolving your IT challenges.

Error thrown when enabling disk checking on RHEL 5.6

This question has been answered by mjplakus

Filesystem of /home/bb/bbc1.9i-btf/tmp is FULL

Any ideas what would be causing this error as soon as the client was started? There is no shortage of disk or quotas.

Verified Answer
  • Just had to revisit this problem today. Turns out my original solution wasn't entirely accurate. A combination of adding DFSORT="-k4n" to bbsys.local and removing the + signs from lines 60 and 75 of bb-disk.sh fixed the issue. It seems RHEL was parsing the commands differently than earlier versions of *Nix.

All Replies
  • This link might help you: http://communities.quest.com/community/big_brother/blog/2011/02/07/filesystem-of-homebbbbc440-bbpetmp-is-full-what-does-that-mean

  • What is DFSORT trying to do? Your link didn't help. If I knew what DFSORT was trying to accomplish I could work out the switches. I tried adding a DFSORT line in bbsys.local and changing theDFSORT line in bbsys.sh

    Tried running the bb-disk.sh command separately--Got this result:

    [bb@server bin]$ ./bb-disk.sh

    /bin/sort: open failed: +4: No such file or directory

    bb-combo.sh: BBCOMBOID variable is not set or has not been exported

    combo add request ignored, sending status immediately

  • bb-disk.sh is called from bb-local.sh so that's the reasons it failed (and possibly other reasons).

    Michael, are you on RedHat? or other linux platforms?

    check in etc/bbsys.local if DF is set something like this

    DF="/bin/df -kP"

    it's required if your "df" spans a filesystem entry over multiple lines. as in (df -k)

    10.4.49.81:/export/home

    46730240 12835840 33426432 28% /homes

    with df -kP, it'll look like this

    10.4.49.81:/export/home 46730240 12835840 33426432 28% /homes

    if you need to make the change, restart the client

  • OS is Red Hat Enterprise Linux 5.6

    The bbsys.local reads as described above. I have never changed it.

  • We have a winner! http://www.vatofknow.com/archives/314 

     

    <quote from link above>

    Error in disk: Filesystem of $BBTMP is FULL

    I seem to get this every time.  There seems to be an error in the file /usr/local/bb/bin/bb-disk.sh.  Edit the following two lines as follows:

    line 60:eval “$DFCMD | $EGREP \”$DFUSE\” | $EGREP -v \”$DFEXCLUDE\” | $SORT \”+${DFSORT}\” > $BBTMP/DFOUT.$$”
    line 75: wclen1=`eval “$DFCMD | $EGREP \”$DFUSE\” | $EGREP -v \”$DFEXCLUDE\” | $SORT \”+${DFSORT}\” | $WC”`

    The
    $SORT \”+${DFSORT}\”
    is being evaluated to
    /bin/sort “+4″
    and it upsets sort (it thinks +4 is a file).

    I fixed the problem by adding the option -k to both lines:

    line 60:eval “$DFCMD | $EGREP \”$DFUSE\” | $EGREP -v \”$DFEXCLUDE\” | $SORT -k \”+${DFSORT}\” > $BBTMP/DFOUT.$$”
    line 75: wclen1=`eval “$DFCMD | $EGREP \”$DFUSE\” | $EGREP -v \”$DFEXCLUDE\” | $SORT -k \”+${DFSORT}\” | $WC”`

    </quote>

  • actually, you need to change the DFSORT in etc/bbsys.local. It's cleaner.

    DFSORT="-k4n"

    that should do it. (as well as a BB client stop/start)

  • I tried that before I posted here. Result was the same as when there was no DFSORT line in the bbsys.local at all which is to say it generated the same "Filesystem of /home/bb/bbc1.9i-btf/tmp is FULL" error in the status display.

  • did you restart the BB client? in any case, if your change works, keep it

  • Restarted the client with every change no matter how trivial it seemed to insure we knew what worked.

  • Just had to revisit this problem today. Turns out my original solution wasn't entirely accurate. A combination of adding DFSORT="-k4n" to bbsys.local and removing the + signs from lines 60 and 75 of bb-disk.sh fixed the issue. It seems RHEL was parsing the commands differently than earlier versions of *Nix.