Stopping Big Brother from Reporting that the Messages File is Empty - BB Custom Topics A - D - Big Brother - Dell Community

Stopping Big Brother from Reporting that the Messages File is Empty

Big Brother

Big Brother
Access more than 800 custom test extensions to share or use in resolving your IT challenges.

Stopping Big Brother from Reporting that the Messages File is Empty

This question has been answered by robert.croteau

I have BBPE client V4.40 on a solaris box

I added CHKMSGLEN=FALSE to bbdef.sh but i keep on receiving /var/adm/messages is empty

am i missing something ?

Verified Answer
  • Did you restart the BB client? also the change is in bbdef-client.sh (but I believe that's what you meant in the first place but just in case)

    To take effect, the BB client must be restarted.

All Replies
  • Did you restart the BB client? also the change is in bbdef-client.sh (but I believe that's what you meant in the first place but just in case)

    To take effect, the BB client must be restarted.

  • Ahhh i added it to bbdef.sh....

    changed it in bbdef-client.sh and all is good !

    Thanks !

  • This is what I did on my Solaris machine. Adds "System log Rotated" message to /var/adm/messages file when it rotates

    How to avoid empty messages file during rotation:
    add logger string to /etc/logadm.conf
    /var/adm/messages -C 4 -P 'Tue Jan 29 16:54:33 2008' -a 'kill -HUP `cat /var/run/syslog.pid`; /bin/logger -plocal0.notice System log rotated'
    NOTE:local0.notice must be added to /etc/syslog.conf
    *.err;kern.debug;daemon.notice;mail.crit;local0.notice /var/adm/messages

    you will need to restart syslogd service:

    Solaris 10

    How to restart syslogd service:
    svcadm disable system/system-log:default
    svcadm enable system/system-log:default
    svcadm restart system/system-log:default